summaryrefslogtreecommitdiffstats
path: root/python-zope-filerepresentation/F-13/python-zope-filerepresentation.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-zope-filerepresentation/F-13/python-zope-filerepresentation.spec')
-rw-r--r--python-zope-filerepresentation/F-13/python-zope-filerepresentation.spec52
1 files changed, 52 insertions, 0 deletions
diff --git a/python-zope-filerepresentation/F-13/python-zope-filerepresentation.spec b/python-zope-filerepresentation/F-13/python-zope-filerepresentation.spec
new file mode 100644
index 0000000..c028095
--- /dev/null
+++ b/python-zope-filerepresentation/F-13/python-zope-filerepresentation.spec
@@ -0,0 +1,52 @@
+%if ! (0%{?fedora} > 12 || 0%{?rhel} > 5)
+%{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")}
+%endif
+%global modname zope.filerepresentation
+%global version 3.6.0
+%global release 1
+
+Summary: File-system Representation Interfaces
+Name: python-zope-filerepresentation
+Version: %{version}
+Release: %{release}%{?dist}
+Source0: http://pypi.python.org/packages/source/z/%{modname}/%{modname}-%{version}.tar.gz
+License: ZPLv2.1
+Group: Development/Libraries
+BuildArch: noarch
+URL: http://pypi.python.org/pypi/zope.filerepresentation
+
+BuildRequires: python2-devel
+BuildRequires: python-setuptools
+Requires: python-zope-filesystem
+Requires: python-setuptools
+Requires: python-zope-interface
+
+%description
+The interfaces defined here are used for file-system and file-system-like
+representations of objects, such as file-system synchronization, FTP, PUT, and
+WebDAV.
+
+%prep
+%setup -q -n %{modname}-%{version}
+
+%build
+python setup.py build
+
+%install
+rm -rf $RPM_BUILD_ROOT
+python setup.py install --root=$RPM_BUILD_ROOT
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%files
+%defattr(-,root,root,-)
+%doc CHANGES.txt README.txt
+%{python_sitelib}/zope/filerepresentation/
+%{python_sitelib}/%{modname}-*.egg-info
+%{python_sitelib}/%{modname}-*-nspkg.pth
+
+
+%changelog
+* Wed Jun 16 2010 Robin Lee <robinlee.sysu@gmail.com> - 3.6.0-1
+- Initial packaging