summaryrefslogtreecommitdiffstats
path: root/python-zope-exceptions/F-13/python-zope-exceptions.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-zope-exceptions/F-13/python-zope-exceptions.spec')
-rw-r--r--python-zope-exceptions/F-13/python-zope-exceptions.spec51
1 files changed, 51 insertions, 0 deletions
diff --git a/python-zope-exceptions/F-13/python-zope-exceptions.spec b/python-zope-exceptions/F-13/python-zope-exceptions.spec
new file mode 100644
index 0000000..01e9604
--- /dev/null
+++ b/python-zope-exceptions/F-13/python-zope-exceptions.spec
@@ -0,0 +1,51 @@
+%if ! (0%{?fedora} > 12 || 0%{?rhel} > 5)
+%{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")}
+%endif
+%global modname zope.exceptions
+%global version 3.6.0
+%global release 1
+
+Summary: Zope Exceptions
+Name: python-zope-exceptions
+Version: %{version}
+Release: %{release}%{?dist}
+Source0: http://pypi.python.org/packages/source/z/%{modname}/%{modname}-%{version}.tar.gz
+License: ZPLv2.1
+Group: Development/Libraries
+BuildArch: noarch
+URL: http://cheeseshop.python.org/pypi/zope.exceptions
+
+BuildRequires: python2-devel
+BuildRequires: python-setuptools
+Requires: python-zope-filesystem
+Requires: python-setuptools
+Requires: python-zope-interface
+
+%description
+This package contains exception interfaces and implementations which are so
+general purpose that they don't belong in Zope application-specific packages.
+
+%prep
+%setup -q -n %{modname}-%{version}
+
+%build
+python setup.py build
+
+%install
+rm -rf $RPM_BUILD_ROOT
+python setup.py install --root=$RPM_BUILD_ROOT
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%files
+%defattr(-,root,root,-)
+%doc LICENSE.txt CHANGES.txt README.txt COPYRIGHT.txt
+%{python_sitelib}/zope/exceptions/
+%{python_sitelib}/%{modname}-*.egg-info
+%{python_sitelib}/%{modname}-*-nspkg.pth
+
+
+%changelog
+* Wed Jun 16 2010 Robin Lee <robinlee.sysu@gmail.com> - 3.6.0-1
+- Initial packaging