summaryrefslogtreecommitdiffstats
path: root/python-zope-deprecation/F-13/python-zope-deprecation.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-zope-deprecation/F-13/python-zope-deprecation.spec')
-rw-r--r--python-zope-deprecation/F-13/python-zope-deprecation.spec48
1 files changed, 48 insertions, 0 deletions
diff --git a/python-zope-deprecation/F-13/python-zope-deprecation.spec b/python-zope-deprecation/F-13/python-zope-deprecation.spec
new file mode 100644
index 0000000..aa03d48
--- /dev/null
+++ b/python-zope-deprecation/F-13/python-zope-deprecation.spec
@@ -0,0 +1,48 @@
+%if ! (0%{?fedora} > 12 || 0%{?rhel} > 5)
+%{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")}
+%endif
+%global modname zope.deprecation
+
+Summary: Zope 3 Deprecation Infrastructure
+Name: python-%(echo %{modname} | sed -r 's|\.|-|g')
+Version: 3.4.0
+Release: 1%{?dist}
+Source0: http://pypi.python.org/packages/source/%(echo %{modname} | sed -r 's|^(.).*|\1|')/%{modname}/%{modname}-%{version}.tar.gz
+License: ZPLv2.1
+Group: Development/Libraries
+BuildArch: noarch
+URL: http://www.python.org/pypi/zope.deprecation
+
+BuildRequires: python2-devel
+BuildRequires: python-setuptools
+Requires: python-zope-filesystem
+Requires: python-setuptools
+
+%description
+This package provides a simple function called 'deprecated(names, reason)' to
+deprecate the previously mentioned Python objects.
+
+%prep
+%setup -q -n %{modname}-%{version}
+
+%build
+python setup.py build
+
+%install
+rm -rf $RPM_BUILD_ROOT
+python setup.py install --root=$RPM_BUILD_ROOT
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%files
+%defattr(-,root,root,-)
+%doc README.txt
+%{python_sitelib}/%(echo %{modname} | sed -r 's|\.|/|g')
+%{python_sitelib}/%{modname}-*.egg-info
+%{python_sitelib}/%{modname}-*-nspkg.pth
+
+
+%changelog
+* Tue Jul 6 2010 Robin Lee <robinlee.sysu@gmail.com> - 3.4.0-1
+- Initial packaging