summaryrefslogtreecommitdiffstats
path: root/python-zope-deferredimport/F-13/python-zope-deferredimport.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-zope-deferredimport/F-13/python-zope-deferredimport.spec')
-rw-r--r--python-zope-deferredimport/F-13/python-zope-deferredimport.spec57
1 files changed, 57 insertions, 0 deletions
diff --git a/python-zope-deferredimport/F-13/python-zope-deferredimport.spec b/python-zope-deferredimport/F-13/python-zope-deferredimport.spec
new file mode 100644
index 0000000..13da855
--- /dev/null
+++ b/python-zope-deferredimport/F-13/python-zope-deferredimport.spec
@@ -0,0 +1,57 @@
+%if ! (0%{?fedora} > 12 || 0%{?rhel} > 5)
+%{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")}
+%endif
+%global modname zope.deferredimport
+%global version 3.5.2
+%global release 1
+
+Summary: Importing names that will only be resolved when used
+Name: python-zope-deferredimport
+Version: %{version}
+Release: %{release}%{?dist}
+Source0: http://pypi.python.org/packages/source/z/%{modname}/%{modname}-%{version}.tar.gz
+License: ZPLv2.1
+Group: Development/Libraries
+BuildArch: noarch
+URL: http://pypi.python.org/pypi/zope.deferredimport
+
+BuildRequires: python2-devel
+BuildRequires: python-setuptools
+Requires: python-zope-filesystem
+Requires: python-zope-proxy
+Requires: python-setuptools
+
+%description
+Often, especially for package modules, you want to import names for
+convenience, but not actually perform the imports until necessary.
+The zope.deferredimport package provided facilities for defining names
+in modules that will be imported from somewhere else when used. You
+can also cause deprecation warnings to be issued when a variable is
+used.
+
+%prep
+%setup -q -n %{modname}-%{version}
+
+%build
+python setup.py build
+
+%install
+rm -rf $RPM_BUILD_ROOT
+python setup.py install --root=$RPM_BUILD_ROOT
+rm -f $RPM_BUILD_ROOT%{python_sitelib}/zope/deferredimport/*.txt
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%files
+%defattr(-,root,root,-)
+%doc LICENSE.txt CHANGES.txt COPYRIGHT.txt
+%doc src/zope/deferredimport/*.txt
+%{python_sitelib}/zope/deferredimport/
+%{python_sitelib}/%{modname}-*.egg-info
+%{python_sitelib}/%{modname}-*-nspkg.pth
+
+
+%changelog
+* Wed Jun 16 2010 Robin Lee <robinlee.sysu@gmail.com> - 3.5.2-1
+- Initial packaging