summaryrefslogtreecommitdiffstats
path: root/python-zope-app-content/F-13/python-zope-app-content.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-zope-app-content/F-13/python-zope-app-content.spec')
-rw-r--r--python-zope-app-content/F-13/python-zope-app-content.spec52
1 files changed, 52 insertions, 0 deletions
diff --git a/python-zope-app-content/F-13/python-zope-app-content.spec b/python-zope-app-content/F-13/python-zope-app-content.spec
new file mode 100644
index 0000000..7fe63a0
--- /dev/null
+++ b/python-zope-app-content/F-13/python-zope-app-content.spec
@@ -0,0 +1,52 @@
+%if ! (0%{?fedora} > 12 || 0%{?rhel} > 5)
+%{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")}
+%endif
+%global modname zope.app.content
+
+Summary: Zope Content Type
+Name: python-%(echo %{modname} | sed -r 's|\.|-|g')
+Version: 3.4.0
+Release: 1%{?dist}
+Source0: http://pypi.python.org/packages/source/%(echo %{modname} | sed -r 's|^(.).*|\1|')/%{modname}/%{modname}-%{version}.tar.gz
+License: ZPLv2.1
+Group: Development/Libraries
+BuildArch: noarch
+URL: http://cheeseshop.python.org/pypi/zope.app.content
+
+BuildRequires: python2-devel
+BuildRequires: python-setuptools
+Requires: python-zope-filesystem
+Requires: python-setuptools
+Requires: python-zope-app-component
+Requires: python-zope-app-interface
+Requires: python-zope-interface
+Requires: python-zope-schema
+
+%description
+This package defines an 'IInterface' that allows the developer to mark
+interfaces as content types.
+
+%prep
+%setup -q -n %{modname}-%{version}
+
+%build
+python setup.py build
+
+%install
+rm -rf $RPM_BUILD_ROOT
+python setup.py install --root=$RPM_BUILD_ROOT
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%files
+%defattr(-,root,root,-)
+%doc CHANGES.txt README.txt
+%{python_sitelib}/%(echo %{modname} | sed -r 's|\.|/|g')
+%{python_sitelib}/%{modname}-*.egg-info
+%{python_sitelib}/%{modname}-*-nspkg.pth
+
+
+%changelog
+* Tue Jul 6 2010 Robin Lee <robinlee.sysu@gmail.com> - 3.4.0-1
+- Initial packaging