summaryrefslogtreecommitdiffstats
path: root/python-z3c-testsetup/F-13/python-z3c-testsetup.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-z3c-testsetup/F-13/python-z3c-testsetup.spec')
-rw-r--r--python-z3c-testsetup/F-13/python-z3c-testsetup.spec49
1 files changed, 49 insertions, 0 deletions
diff --git a/python-z3c-testsetup/F-13/python-z3c-testsetup.spec b/python-z3c-testsetup/F-13/python-z3c-testsetup.spec
new file mode 100644
index 0000000..d48faf0
--- /dev/null
+++ b/python-z3c-testsetup/F-13/python-z3c-testsetup.spec
@@ -0,0 +1,49 @@
+%if ! (0%{?fedora} > 12 || 0%{?rhel} > 5)
+%{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")}
+%endif
+%global modname z3c.testsetup
+
+Summary: Easier test setup for Zope 3 projects and other Python packages
+Name: python-%(echo %{modname} | sed -r 's|\.|-|')
+Version: 0.7
+Release: 1%{?dist}
+Source0: http://pypi.python.org/packages/source/%(echo %{modname} | sed -r 's|^(.).*|\1|')/%{modname}/%{modname}-%{version}.tar.gz
+License: ZPLv2.1
+Group: Development/Libraries
+BuildArch: noarch
+URL: http://pypi.python.org/pypi/z3c.testsetup
+
+BuildRequires: python2-devel
+BuildRequires: python-setuptools
+Requires: python-zope-filesystem
+Requires: python-setuptools
+Requires: python-zope-testing
+Requires: python-martian
+
+%description
+z3c.testsetup: easy test setup for zope 3 and python projects
+
+%prep
+%setup -q -n %{modname}-%{version}
+
+%build
+python setup.py build
+
+%install
+rm -rf $RPM_BUILD_ROOT
+python setup.py install --root=$RPM_BUILD_ROOT
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%files
+%defattr(-,root,root,-)
+%doc DEVELOPMENT.txt LICENSE.txt CHANGES.txt README.txt COPYRIGHT.txt
+%{python_sitelib}/%(echo %{modname} | sed -r 's|\.|/|')
+%{python_sitelib}/%{modname}-*.egg-info
+%{python_sitelib}/%{modname}-*-nspkg.pth
+
+
+%changelog
+* Sun Jul 4 2010 Robin Lee <robinlee.sysu@gmail.com> - 0.7-1
+- Initial packaging