summaryrefslogtreecommitdiffstats
path: root/python-ThreadLock/F-13/python-ThreadLock.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-ThreadLock/F-13/python-ThreadLock.spec')
-rw-r--r--python-ThreadLock/F-13/python-ThreadLock.spec49
1 files changed, 49 insertions, 0 deletions
diff --git a/python-ThreadLock/F-13/python-ThreadLock.spec b/python-ThreadLock/F-13/python-ThreadLock.spec
new file mode 100644
index 0000000..58a96b5
--- /dev/null
+++ b/python-ThreadLock/F-13/python-ThreadLock.spec
@@ -0,0 +1,49 @@
+%if ! (0%{?fedora} > 12 || 0%{?rhel} > 5)
+%{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print(get_python_lib(1))")}
+%endif
+%global modname ThreadLock
+%global version 2.13.0
+%global release 1
+
+Summary: Special ThreadLock objects used in Zope2
+Name: python-%{modname}
+Version: %{version}
+Release: %{release}%{?dist}
+Source0: http://pypi.python.org/packages/source/T/%{modname}/%{modname}-%{version}.zip
+License: ZPLv2.1
+Group: Development/Libraries
+URL: http://pypi.python.org/pypi/ThreadLock
+
+BuildRequires: python2-devel
+BuildRequires: python-setuptools
+#BuildRequires: python-ExtensionClass-devel
+Requires: python-ExtensionClass
+
+%description
+ThreadLock provides special objects used in some Zope2 internals like ZRDB.
+
+%prep
+%setup -q -n %{modname}-%{version}
+
+%build
+env CFLAGS="$RPM_OPT_FLAGS" python setup.py build
+
+%install
+rm -rf $RPM_BUILD_ROOT
+python setup.py install --root=$RPM_BUILD_ROOT
+# remove contained source file(s)
+find $RPM_BUILD_ROOT -name '*.c' -type f -print0 | xargs -0 rm -fv
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%files
+%defattr(-,root,root,-)
+%doc CHANGES.txt README.txt
+%{python_sitearch}/%{modname}/
+%{python_sitearch}/%{modname}-*.egg-info
+
+
+%changelog
+* Tue Jun 15 2010 Robin Lee <robinlee.sysu@gmail.com> - 2.13.0-1
+- Initial packaging