summaryrefslogtreecommitdiffstats
path: root/python-zc-buildout/F-13/python-zc-buildout.spec
diff options
context:
space:
mode:
authorRobin Lee <robinlee.sysu@gmail.com>2010-07-10 13:53:58 +0800
committerRobin Lee <robinlee.sysu@gmail.com>2010-07-10 13:53:58 +0800
commit0d097ef27b35f0929e2f9e4473adfe696b7e7224 (patch)
treefd8c71e97c762bb908f57aa7d630c364cc98a189 /python-zc-buildout/F-13/python-zc-buildout.spec
parent4b37e969e345418d3e57447562cd7826423cf949 (diff)
downloadzope-rpm-0d097ef27b35f0929e2f9e4473adfe696b7e7224.tar.gz
zope-rpm-0d097ef27b35f0929e2f9e4473adfe696b7e7224.tar.xz
zope-rpm-0d097ef27b35f0929e2f9e4473adfe696b7e7224.zip
python-grok 1.1.1-1, grokproject 2.0.1-1 and all their dependencies
Diffstat (limited to 'python-zc-buildout/F-13/python-zc-buildout.spec')
-rw-r--r--python-zc-buildout/F-13/python-zc-buildout.spec53
1 files changed, 53 insertions, 0 deletions
diff --git a/python-zc-buildout/F-13/python-zc-buildout.spec b/python-zc-buildout/F-13/python-zc-buildout.spec
new file mode 100644
index 0000000..09c5997
--- /dev/null
+++ b/python-zc-buildout/F-13/python-zc-buildout.spec
@@ -0,0 +1,53 @@
+%if ! (0%{?fedora} > 12 || 0%{?rhel} > 5)
+%{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")}
+%endif
+%global modname zc.buildout
+
+Summary: System for managing development buildouts
+Name: python-%(echo %{modname} | sed -r 's|\.|-|')
+Version: 1.4.3
+Release: 1%{?dist}
+Source0: http://pypi.python.org/packages/source/%(echo %{modname} | sed -r 's|^(.).*|\1|')/%{modname}/%{modname}-%{version}.tar.gz
+License: ZPLv2.1
+Group: Development/Libraries
+BuildArch: noarch
+URL: http://buildout.org
+
+BuildRequires: python2-devel
+BuildRequires: python-setuptools
+Requires: python-zope-filesystem
+Requires: python-setuptools
+
+%description
+The Buildout project provides support for creating applications,
+especially Python applications. It provides tools for assembling
+applications from multiple parts, Python or otherwise. An application
+may actually contain multiple programs, processes, and configuration
+settings.
+
+%prep
+%setup -q -n %{modname}-%{version}
+
+%build
+python setup.py build
+
+%install
+rm -rf $RPM_BUILD_ROOT
+python setup.py install --root=$RPM_BUILD_ROOT
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%files
+%defattr(-,root,root,-)
+%doc CHANGES.txt README.txt todo.txt DEVELOPERS.txt doc/ specifications/
+%{python_sitelib}/%(echo %{modname} | sed -r 's|\.|/|')
+%{_bindir}/buildout
+%exclude %{_usr}/README.txt
+%{python_sitelib}/%{modname}-*.egg-info
+%{python_sitelib}/%{modname}-*-nspkg.pth
+
+
+%changelog
+* Sun Jul 4 2010 Robin Lee <robinlee.sysu@gmail.com> - 1.4.3-1
+- Initial packaging