summaryrefslogtreecommitdiffstats
path: root/python-Persistence/F-13/python-Persistence.spec
diff options
context:
space:
mode:
authorRobin Lee <robinlee.sysu@gmail.com>2010-06-17 22:18:59 +0800
committerRobin Lee <robinlee.sysu@gmail.com>2010-06-17 22:18:59 +0800
commitbc057b279eb24cbf66ad6ff917b46fc0e375af8b (patch)
treec7d1a5836df04c6ed399ea8556d37dc734156919 /python-Persistence/F-13/python-Persistence.spec
parent839c24b70dac3d1c5e0fec4e76911534091501c2 (diff)
downloadzope-rpm-bc057b279eb24cbf66ad6ff917b46fc0e375af8b.tar.gz
zope-rpm-bc057b279eb24cbf66ad6ff917b46fc0e375af8b.tar.xz
zope-rpm-bc057b279eb24cbf66ad6ff917b46fc0e375af8b.zip
most of the denpendencies of Zope 2.12
Diffstat (limited to 'python-Persistence/F-13/python-Persistence.spec')
-rw-r--r--python-Persistence/F-13/python-Persistence.spec54
1 files changed, 54 insertions, 0 deletions
diff --git a/python-Persistence/F-13/python-Persistence.spec b/python-Persistence/F-13/python-Persistence.spec
new file mode 100644
index 0000000..1f448ce
--- /dev/null
+++ b/python-Persistence/F-13/python-Persistence.spec
@@ -0,0 +1,54 @@
+%if ! (0%{?fedora} > 12 || 0%{?rhel} > 5)
+%{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print(get_python_lib(1))")}
+%endif
+%global modname Persistence
+%global version 2.13.2
+%global release 1
+
+Summary: Persistent ExtensionClass
+Name: python-%{modname}
+Version: %{version}
+Release: %{release}%{?dist}
+Source0: http://pypi.python.org/packages/source/P/%{modname}/%{modname}-%{version}.zip
+# lp587760, patch provided by Artur Zaprzała <https://launchpad.net/~arturz>
+#Patch0: Persistence-2.13.1-tp_basicsize.patch
+License: ZPLv2.1
+Group: Development/Libraries
+URL: http://pypi.python.org/pypi/Persistence
+
+BuildRequires: python2-devel
+#BuildRequires: python-ExtensionClass-devel
+BuildRequires: python-setuptools
+Requires: python-ExtensionClass
+Requires: python-ZODB3
+
+%description
+This package provides a variant of the persistent base class that's an
+ExtensionClass. Unless you need ExtensionClass semantics, you probably want to
+use persistent.Persistent from ZODB3.
+
+%prep
+%setup -q -n %{modname}-%{version}
+#%patch0 -p1 -b .tp_basicsize
+
+%build
+env CFLAGS="$RPM_OPT_FLAGS" python setup.py build
+
+%install
+rm -rf $RPM_BUILD_ROOT
+python setup.py install --root=$RPM_BUILD_ROOT
+# remove contained source file(s)
+find $RPM_BUILD_ROOT -name '*.c' -type f -print0 | xargs -0 rm -fv
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%files
+%defattr(-,root,root,-)
+%doc CHANGES.txt COPYRIGHT.txt LICENSE.txt README.txt
+%{python_sitearch}/%{modname}/
+%{python_sitearch}/%{modname}-*.egg-info
+
+%changelog
+* Thu Jun 17 2010 Robin Lee <robinlee.sysu@gmail.com> - 2.13.2-1
+- Initial packaging