summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorMichael DeHaan <mdehaan@redhat.com>2008-02-25 14:29:57 -0500
committerMichael DeHaan <mdehaan@redhat.com>2008-02-25 14:29:57 -0500
commitf2e2df8491b9e9d71ed88855e2b043f76d22e119 (patch)
tree5a4b69c9b9e38057256624f1c173f59d928487e5 /setup.py
parent6fd13e5c3c572ebb64d70cfaa2f2160a13dbc838 (diff)
downloadthird_party-func-f2e2df8491b9e9d71ed88855e2b043f76d22e119.tar.gz
third_party-func-f2e2df8491b9e9d71ed88855e2b043f76d22e119.tar.xz
third_party-func-f2e2df8491b9e9d71ed88855e2b043f76d22e119.zip
Revert "first pass at splitting off certmaster"
This reverts commit 6fd13e5c3c572ebb64d70cfaa2f2160a13dbc838.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py13
1 files changed, 8 insertions, 5 deletions
diff --git a/setup.py b/setup.py
index b627b11..332ff96 100644
--- a/setup.py
+++ b/setup.py
@@ -18,9 +18,8 @@ if __name__ == "__main__":
etcmodpath = "/etc/%s/modules" % NAME
initpath = "/etc/init.d/"
logpath = "/var/log/%s/" % NAME
- certdir = "/var/lib/certmaster/"
- pkidir = "/etc/pki/%s" % NAME
- libdir = "/var/lib/%s" % NAME
+ certdir = "/var/lib/%s/certmaster" % NAME
+ pkipath = "/etc/pki/%s" % NAME
rotpath = "/etc/logrotate.d"
aclpath = "%s/minion-acl.d" % etcpath
setup(
@@ -32,6 +31,7 @@ if __name__ == "__main__":
license = "GPL",
scripts = [
"scripts/funcd", "scripts/func",
+ "scripts/certmaster", "scripts/certmaster-ca",
"scripts/func-inventory",
"scripts/func-create-module",
],
@@ -51,17 +51,20 @@ if __name__ == "__main__":
"%s/minion/modules.netapp.vol" % NAME
],
data_files = [(initpath, ["init-scripts/funcd"]),
+ (initpath, ["init-scripts/certmaster"]),
(etcpath, ["etc/minion.conf"]),
+ (etcpath, ["etc/certmaster.conf"]),
(etcmodpath, []),
(manpath, ["docs/func.1.gz"]),
(manpath, ["docs/func-inventory.1.gz"]),
(manpath, ["docs/funcd.1.gz"]),
+ (manpath, ["docs/certmaster.1.gz"]),
+ (manpath, ["docs/certmaster-ca.1.gz"]),
(rotpath, ['etc/func_rotate']),
(logpath, []),
- (libdir, []),
(certdir, []),
- (pkidir, []),
(etcpath, []),
+ (pkipath, []),
(aclpath, [])
],
description = SHORT_DESC,