summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorMichael DeHaan <mdehaan@redhat.com>2007-03-19 18:56:59 -0400
committerJim Meyering <jim@meyering.net>2007-03-19 18:56:59 -0400
commit6d6082d62d7e5fdc4014455a09316de9e36b6786 (patch)
treeaa484d1d2ed01f9fbcb39b372e9f26f7e35e67ba /setup.py
parent3797448bd957a39f43432d3399a5e2482cec533a (diff)
downloadthird_party-cobbler-6d6082d62d7e5fdc4014455a09316de9e36b6786.tar.gz
third_party-cobbler-6d6082d62d7e5fdc4014455a09316de9e36b6786.tar.xz
third_party-cobbler-6d6082d62d7e5fdc4014455a09316de9e36b6786.zip
Most of these diffs come from directory reorg/cleanup, though the main feature here is the start of a better --import command that creates significantly shorter paths and can work more reliably on mounted DVD images (losetup or otherwise). Detection of kickstarts based on paths needs to be augmented by additional means for this to really work. However, changes going in here (and still more to come) result in cleaner names for imported profiles, and substantially shorter kernel option command lines, which is needed to keep under the 255 limit. There is also some work here going in to template out all of the files for PXE, reducing the amount of code in action_sync and also making PXE setups much more customizable (menu choices, titles, random parameters, ipappend 2, etc) without patching the source. "tree" on import is also attached now to the distro, not the profile. So, whew, that's a lot.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py31
1 files changed, 18 insertions, 13 deletions
diff --git a/setup.py b/setup.py
index 6fac783..2aee2b9 100644
--- a/setup.py
+++ b/setup.py
@@ -29,6 +29,7 @@ if __name__ == "__main__":
vw_distros = "/var/www/cobbler/distros"
vw_systems = "/var/www/cobbler/systems"
vw_profiles = "/var/www/cobbler/profiles"
+ vw_links = "/var/www/cobbler/links"
tftp_cfg = "/tftpboot/pxelinux.cfg"
tftp_images = "/tftpboot/images"
setup(
@@ -42,21 +43,24 @@ if __name__ == "__main__":
"cobbler",
"cobbler/yaml"
],
- scripts = ["cobbler/cobbler", "cobbler/cobbler_syslogd"],
+ scripts = ["scripts/cobbler", "scripts/cobbler_syslogd"],
data_files = [
# (docspath, ['README']),
- (wwwpath, ['watcher.py']),
- (cobpath, ['elilo-3.6-ia64.efi']),
- (cobpath, ['menu.c32']),
- (etcpath, ['kickstart_fc5.ks']),
- (etcpath, ['kickstart_fc6.ks']),
- (etcpath, ['kickstart_fc6_domU.ks']),
- (etcpath, ['default.ks']),
- (etcpath, ['dhcp.template']),
- (etcpath, ['pxe.template']),
- (manpath, ['cobbler.1.gz']),
- (etcpath, ['rsync.exclude']),
- (initpath, ['cobblersyslogd']),
+ (wwwpath, ['scripts/watcher.py']),
+ (cobpath, ['loaders/elilo-3.6-ia64.efi']),
+ (cobpath, ['loaders/menu.c32']),
+ (etcpath, ['kickstarts/kickstart_fc5.ks']),
+ (etcpath, ['kickstarts/kickstart_fc6.ks']),
+ (etcpath, ['kickstarts/kickstart_fc6_domU.ks']),
+ (etcpath, ['kickstarts/default.ks']),
+ (etcpath, ['templates/dhcp.template']),
+ (etcpath, ['templates/pxedefault.template']),
+ (etcpath, ['templates/pxesystem.template']),
+ (etcpath, ['templates/pxesystem_ia64.template']),
+ (etcpath, ['templates/pxeprofile.template']),
+ (manpath, ['docs/cobbler.1.gz']),
+ (etcpath, ['templates/rsync.exclude']),
+ (initpath, ['scripts/cobblersyslogd']),
(logpath, []),
(logpath2, []),
(logpath3, []),
@@ -69,6 +73,7 @@ if __name__ == "__main__":
(vw_images, []),
(vw_systems, []),
(vw_profiles, []),
+ (vw_links, []),
(tftp_cfg, []),
(tftp_images, []),
],