summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am20
1 files changed, 20 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
new file mode 100644
index 0000000..31ea7a8
--- /dev/null
+++ b/src/Makefile.am
@@ -0,0 +1,20 @@
+AM_CPPFLAGS = \
+ -DG_LOG_DOMAIN=\"Sonacy\" \
+ -DPREFIX="\"$(prefix)"\" \
+ -DSYSCONFDIR=\""$(sysconfdir)"\" \
+ -DDATADIR=\""$(datadir)"\" \
+ -DLIBDIR=\""$(libdir)"\" \
+ -DGNOMELOCALEDIR=\""$(datadir)/locale"\" \
+ -I$(top_srcdir) \
+ -I$(top_builddir) \
+ $(SONANCY_CFLAGS)
+
+bin_PROGRAMS = sonancy
+
+sonancy_SOURCES = \
+ sonancy-app.c sonancy-app.h \
+ sonancy-main.c \
+ sonancy-xml.c sonancy-xml.h
+
+sonancy_LDADD= \
+ $(SONANCY_LIBS)