summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorBill Peck <bpeck@redhat.com>2015-05-05 14:12:12 -0400
committerBill Peck <bpeck@redhat.com>2015-05-05 14:12:12 -0400
commita86d5c0a2815ce2bc288a76ff6edc103ff8eb3a5 (patch)
treec49e3624b55ee96db6a79fb8fb6edf79637eed43 /setup.py
downloadtaskrepo-a86d5c0a2815ce2bc288a76ff6edc103ff8eb3a5.tar.gz
taskrepo-a86d5c0a2815ce2bc288a76ff6edc103ff8eb3a5.tar.xz
taskrepo-a86d5c0a2815ce2bc288a76ff6edc103ff8eb3a5.zip
initial commit
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py80
1 files changed, 80 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..7ebcc46
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,80 @@
+# This file is part of git-taskrepo.
+# Copyright (C) 2015 Red Hat, Inc.
+#
+# fedmsg is free software; you can redistribute it and/or
+# modify it under the terms of the GNU Lesser General Public
+# License as published by the Free Software Foundation; either
+# version 2.1 of the License, or (at your option) any later version.
+#
+# fedmsg is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# Lesser General Public License for more details.
+#
+# You should have received a copy of the GNU Lesser General Public
+# License along with fedmsg; if not, write to the Free Software
+# Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA
+#
+# Authors: Ralph Bean <rbean@redhat.com>
+# Authors: Bill Peck <bpeck@redhat.com>
+#
+
+try:
+ from setuptools import setup
+except ImportError:
+ from ez_setup import use_setuptools
+ use_setuptools()
+ from setuptools import setup
+
+import sys
+
+# Ridiculous as it may seem, we need to import multiprocessing and
+# logging here in order to get tests to pass smoothly on python 2.7.
+try:
+ import multiprocessing
+ import logging
+except Exception:
+ pass
+
+
+install_requires = [
+ 'GitPython',
+]
+tests_require = [
+ 'nose',
+]
+
+if sys.version_info[0] == 2 and sys.version_info[1] <= 6:
+ install_requires.extend([
+ 'argparse',
+ 'ordereddict',
+ ])
+ tests_require.extend([
+ 'unittest2',
+ ])
+
+
+setup(
+ name='git-taskrepo',
+ version='0.1.1',
+ description="Manages git repos of tasks",
+ long_description="Manages git repos of tasks",
+ author='Bill Peck',
+ author_email='bpeck@redhat.com',
+ url='http://github.com/p3ck/git-taskrepo/',
+ license='LGPLv2+',
+ install_requires=install_requires,
+ tests_require=tests_require,
+ test_suite='nose.collector',
+ packages=[
+ 'git_taskrepo',
+ 'git_taskrepo.sub_commands',
+ ],
+ include_package_data=True,
+ zip_safe=False,
+ entry_points={
+ 'console_scripts': [
+ "git-taskrepo=git_taskrepo.main:main",
+ ],
+ }
+)