summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@cardoe.com>2013-11-18 16:16:23 -0600
committerDaniel P. Berrange <berrange@redhat.com>2013-11-22 14:45:48 +0000
commitb197b1052b439f9aa432a016b82ea51b8e744e2f (patch)
tree74e08749a45bbed4b52973c79ada224a086591d6 /setup.py
parentebe519a6a3c324d9f9d6e10a5f829cea66211109 (diff)
downloadlibvirt-python-v8-b197b1052b439f9aa432a016b82ea51b8e744e2f.tar.gz
libvirt-python-v8-b197b1052b439f9aa432a016b82ea51b8e744e2f.tar.xz
libvirt-python-v8-b197b1052b439f9aa432a016b82ea51b8e744e2f.zip
Break generator.py to be called per module
Since we don't always want to build all the modules, and there might be more modules added in the future but we want to retain backwards compatibility with older libvirts, change generator.py to be called once per module instead of with all modules at once.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py4
1 files changed, 3 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 4de9489..5b72b09 100644
--- a/setup.py
+++ b/setup.py
@@ -100,7 +100,9 @@ class my_build(build):
def run(self):
apis = self.get_api_xml_files()
- self.spawn(["python", "generator.py", apis[0], apis[1], apis[2]])
+ self.spawn(["python", "generator.py", "libvirt", apis[0]])
+ self.spawn(["python", "generator.py", "libvirt-qemu", apis[1]])
+ self.spawn(["python", "generator.py", "libvirt-lxc", apis[2]])
build.run(self)