summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@cardoe.com>2013-11-18 16:16:23 -0600
committerDaniel P. Berrange <berrange@redhat.com>2013-11-21 17:08:43 +0000
commita0bfb1464052041f894e1a5f12a1521ef7429930 (patch)
tree66d10f6b683bc2b844950a8e7473b575be732694 /setup.py
parent5d6138f798d8d5f7b53a2ef01805f40c71016c2a (diff)
downloadlibvirt-python-v7-a0bfb1464052041f894e1a5f12a1521ef7429930.tar.gz
libvirt-python-v7-a0bfb1464052041f894e1a5f12a1521ef7429930.tar.xz
libvirt-python-v7-a0bfb1464052041f894e1a5f12a1521ef7429930.zip
Break generator.py to be called per module
Since we don't always want to build all the modules, and there might be more modules added in the future but we want to retain backwards compatibility with older libvirts, change generator.py to be called once per module instead of with all modules at once.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py4
1 files changed, 3 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 4de9489..5b72b09 100644
--- a/setup.py
+++ b/setup.py
@@ -100,7 +100,9 @@ class my_build(build):
def run(self):
apis = self.get_api_xml_files()
- self.spawn(["python", "generator.py", apis[0], apis[1], apis[2]])
+ self.spawn(["python", "generator.py", "libvirt", apis[0]])
+ self.spawn(["python", "generator.py", "libvirt-qemu", apis[1]])
+ self.spawn(["python", "generator.py", "libvirt-lxc", apis[2]])
build.run(self)