summaryrefslogtreecommitdiffstats
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorJim Meyering <meyering@redhat.com>2010-01-15 11:09:01 +0100
committerJim Meyering <meyering@redhat.com>2010-01-18 09:50:08 +0100
commitce52d4541a4467d200c5c317d2be5d31aa6a0537 (patch)
tree9198297d1530fad44eea8cc5a6a88bd93618605e /tests/Makefile.am
parenta6c8acd06dc71e000d1080ed9fa426211462e016 (diff)
downloadlibvirt-python-split-ce52d4541a4467d200c5c317d2be5d31aa6a0537.tar.gz
libvirt-python-split-ce52d4541a4467d200c5c317d2be5d31aa6a0537.tar.xz
libvirt-python-split-ce52d4541a4467d200c5c317d2be5d31aa6a0537.zip
gnulib added a new syntax-check test: use $(VAR), not @VAR@
The latter is not officially "wrong", but *is* terribly anachronistic. I think automake documentation or comments call that syntax obsolescent. * cfg.mk (_makefile_at_at_check_exceptions): Exempt @SCHEMADIR@ and @SYSCONFDIR@ uses -- there are no Makefile variables for those. * docs/Makefile.am: Use $(INSTALL), not @INSTALL@. * examples/dominfo/Makefile.am: Similar. * examples/domsuspend/Makefile.am: Similar. * proxy/Makefile.am: Similar. * python/Makefile.am: Similar. * python/tests/Makefile.am: Similar. * src/Makefile.am: Similar. * tests/Makefile.am: Similar.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 6011fef..28e24ba 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -30,7 +30,7 @@ clean:
install-data-local:
$(mkinstalldirs) $(DESTDIR)$(EXAMPLE_DIR)
-(for test in $(PYTESTS); \
- do @INSTALL@ -m 0644 $(srcdir)/$$test $(DESTDIR)$(EXAMPLE_DIR) ; done)
+ do $(INSTALL) -m 0644 $(srcdir)/$$test $(DESTDIR)$(EXAMPLE_DIR) ; done)
uninstall-local:
for test in $(PYTESTS); do rm -f $(DESTDIR)$(EXAMPLE_DIR)/$$test; done