summaryrefslogtreecommitdiffstats
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorDaniel P. Berrange <berrange@redhat.com>2013-07-30 11:24:22 +0100
committerDaniel P. Berrange <berrange@redhat.com>2013-07-30 14:13:58 +0100
commita85bf91386293dc07446c82f95e5d5bd4e72c3d5 (patch)
tree1eab834b09f23b70096f4c201ddd82cb82589255 /tests/Makefile.am
parent9dd30d27253563852208103dbad1951dde4c0909 (diff)
downloadlibvirt-python-split-a85bf91386293dc07446c82f95e5d5bd4e72c3d5.tar.gz
libvirt-python-split-a85bf91386293dc07446c82f95e5d5bd4e72c3d5.tar.xz
libvirt-python-split-a85bf91386293dc07446c82f95e5d5bd4e72c3d5.zip
Delete obsolete / unused python test filesCVE-2013-5651CVE-2013-4239
The python/tests directory contains a number of so called "tests" for the python API. These are all hardcoded to look for Xen and cannot be run in any automated fashion, and no one is ever manually running them. Given that they don't meaningully contribute to the test coverage, delete them. For some reason these tests were also copied into the filesystem as part of 'make install'. The change to the RPM in commit 3347a4203278ec93d7b0ceb88b5ed10e4f14765c caused a build failure, since it removed the code which deleted these installed tests. Signed-off-by: Daniel P. Berrange <berrange@redhat.com>
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am52
1 files changed, 0 insertions, 52 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
deleted file mode 100644
index 0fd3c78..0000000
--- a/tests/Makefile.am
+++ /dev/null
@@ -1,52 +0,0 @@
-## Copyright (C) 2005-2011, 2013 Red Hat, Inc.
-##
-## This library is free software; you can redistribute it and/or
-## modify it under the terms of the GNU Lesser General Public
-## License as published by the Free Software Foundation; either
-## version 2.1 of the License, or (at your option) any later version.
-##
-## This library is distributed in the hope that it will be useful,
-## but WITHOUT ANY WARRANTY; without even the implied warranty of
-## MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
-## Lesser General Public License for more details.
-##
-## You should have received a copy of the GNU Lesser General Public
-## License along with this library. If not, see
-## <http://www.gnu.org/licenses/>.
-
-EXAMPLE_DIR = $(datadir)/doc/libvirt-python-$(VERSION)/examples
-
-PYTESTS= \
- basic.py \
- create.py \
- uuid.py \
- error.py \
- node.py
-
-EXTRA_DIST = $(PYTESTS)
-
-if WITH_PYTHON
-tests: $(PYTESTS)
- @echo "## running Python regression tests"
- -@(PYTHONPATH="..:../.libs:../src/.libs:$(srcdir)/../src:$$PYTHONPATH";\
- export PYTHONPATH; \
- LD_LIBRARY_PATH="$(top_builddir)/src/.libs:$$LD_LIBRARY_PATH" ; \
- export LD_LIBRARY_PATH; \
- for test in $(PYTESTS) ; \
- do log=`$(PYTHON) $(srcdir)/$$test` ; \
- if [ "`echo $$log | grep OK`" = "" ] ; then \
- echo "-- $$test" ; echo "$$log" ; fi ; done)
-else
-tests:
-endif
-
-clean:
- rm -f *.pyc core
-
-install-data-local:
- $(mkinstalldirs) $(DESTDIR)$(EXAMPLE_DIR)
- -(for test in $(PYTESTS); \
- do $(INSTALL) -m 0644 $(srcdir)/$$test $(DESTDIR)$(EXAMPLE_DIR) ; done)
-
-uninstall-local:
- for test in $(PYTESTS); do rm -f $(DESTDIR)$(EXAMPLE_DIR)/$$test; done