summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorDaniel P. Berrange <berrange@redhat.com>2013-02-05 12:55:09 +0000
committerDaniel P. Berrange <berrange@redhat.com>2013-02-05 15:40:20 +0000
commit0f102b90f12f59e3a858c7b3d3bd867144f88424 (patch)
tree9e21c2f5e7d9f8696eccfb4456533000da81bd85 /Makefile.am
parent9654aeb6ce522bff6329e3f5e9426e33ee8a45fe (diff)
downloadlibvirt-python-split-0f102b90f12f59e3a858c7b3d3bd867144f88424.tar.gz
libvirt-python-split-0f102b90f12f59e3a858c7b3d3bd867144f88424.tar.xz
libvirt-python-split-0f102b90f12f59e3a858c7b3d3bd867144f88424.zip
Fix missing error constants in libvirt python module
The previous change to the generator, changed too much - only the functions are in 'virerror.c', the constants remained in 'virerror.h' which could not be renamed for API compat reasons. Add a test case to sanity check the generated python bindings Signed-off-by: Daniel P. Berrange <berrange@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index dd69600..ef3c3eb 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -119,6 +119,11 @@ $(libvirtmod_la_OBJECTS): $(GENERATED)
$(libvirtmod_qemu_la_OBJECTS): $(QEMU_GENERATED)
$(libvirtmod_lxc_la_OBJECTS): $(LXC_GENERATED)
+EXTRA_DIST += sanitytest.py
+
+check-local:
+ $(AM_V_GEN)PYTHONPATH=$(abs_topbuilddir):$(abs_topbuilddir)/.libs $(PYTHON) $(srcdir)/sanitytest.py
+
install-data-local:
$(mkinstalldirs) $(DESTDIR)$(pyexecdir)
$(INSTALL) -m 0644 libvirt.py $(DESTDIR)$(pyexecdir)