summaryrefslogtreecommitdiffstats
path: root/mock.spec
diff options
context:
space:
mode:
Diffstat (limited to 'mock.spec')
-rw-r--r--mock.spec106
1 files changed, 82 insertions, 24 deletions
diff --git a/mock.spec b/mock.spec
index 498a037..b99b43f 100644
--- a/mock.spec
+++ b/mock.spec
@@ -11,7 +11,6 @@ Requires: python, yum >= 3.0
Requires(pre): shadow-utils
BuildRequires: libselinux-devel
-
%description
Mock takes a srpm and builds it in a chroot
@@ -19,7 +18,7 @@ Mock takes a srpm and builds it in a chroot
%setup -q
%build
-make
+make CFLAGS="$RPM_OPT_FLAGS"
%install
rm -rf $RPM_BUILD_ROOT
@@ -30,19 +29,21 @@ cd $RPM_BUILD_ROOT/%{_sysconfdir}/%{name}
%if 0%{?fedora:1}
if [ -f fedora-%{fedora}-%{_target_cpu}-core.cfg ]; then
ln -s fedora-%{fedora}-%{_target_cpu}-core.cfg default.cfg
+elif [ -f fedora-%{fedora}-%{_target_cpu}.cfg ]; then
+ ln -s fedora-%{fedora}-%{_target_cpu}.cfg default.cfg
fi
%endif
# if we haven't created a default link yet, try to do so as devel
if [ ! -f default.cfg ]; then
- if [ -f fedora-development-%{_target_cpu}-core.cfg ]; then
- ln -s fedora-development-%{_target_cpu}-core.cfg default.cfg
- elif [ -f fedora-devel-%{_target_cpu}-core.cfg ]; then
- ln -s fedora-devel-%{_target_cpu}-core.cfg default.cfg
- elif [ -f fedora-development-i386-core.cfg ]; then
- ln -s fedora-development-i386-core.cfg default.cfg
- elif [ -f fedora-devel-i386-core.cfg ]; then
- ln -s fedora-devel-i386-core.cfg default.cfg
+ if [ -f fedora-development-%{_target_cpu}.cfg ]; then
+ ln -s fedora-development-%{_target_cpu}.cfg default.cfg
+ elif [ -f fedora-devel-%{_target_cpu}.cfg ]; then
+ ln -s fedora-devel-%{_target_cpu}.cfg default.cfg
+ elif [ -f fedora-development-i386.cfg ]; then
+ ln -s fedora-development-i386.cfg default.cfg
+ elif [ -f fedora-devel-i386.cfg ]; then
+ ln -s fedora-devel-i386.cfg default.cfg
fi
fi
@@ -59,32 +60,89 @@ fi
%doc README ChangeLog buildsys-build.spec
%dir %{_sysconfdir}/%{name}
%config(noreplace) %{_sysconfdir}/%{name}/*.cfg
-%attr(04750, root, mock) %{_bindir}/%{name}
-%{_libexecdir}/mock*
+%{_bindir}/%{name}
+%{_libexecdir}/mock-yum
%{_mandir}/man1/mock.1*
+%attr(04750, root, mock) %{_sbindir}/mock-helper
%attr(02775, root, mock) %dir /var/lib/mock
%{_libdir}/libselinux-mock.so
%changelog
-* Mon Jan 8 2007 Clark Williams <williams@redhat.com>
+* Mon Jun 11 2007 Clark Williams <williams@redhat.com> - 0.7-1
+- fixed bind mount problems
+- added code to allow multiple users to use --no-clean
+- merged mock-0-6-branch to head and changed version
+
+* Thu Jun 7 2007 Clark Williams <williams@redhat.com> - 0.6.17-1
+- added F-7 config files (BZ#242276)
+- modified epel configs for changed mirrorlist location (BZ#239981)
+- added bind mount of /dev (BZ#236428)
+- added copy of /etc/resolv.conf to chroot (BZ#237663 and BZ#238101)
+
+* Tue May 01 2007 Clark Williams <williams@redhat.com> - 0.6.16-1
+- timeout code adds new cmdline option that will kill build process after
+ specified timeout. Useful for automated builds of things that may hang during
+ build and you just want it to fail.
+
+* Tue Apr 10 2007 Clark Williams <williams@redhat.com> - 0.6.15-1
+- Fixed typo in FC4 -epel configs (BZ 235490)
+
+* Sat Feb 24 2007 Clark Williams <williams@redhat.com> - 0.6.14-1
+- Ville Skyttä's fix for RPM_OPT_FLAGS (BZ 226673)
+
+* Tue Feb 20 2007 Clark Williams <williams@redhat.com> - 0.6.13-1
+- Handle --no-clean option when doing yum.conf symlink (BZ 230824)
+
+* Fri Feb 16 2007 Clark Williams <williams@redhat.com> - 0.6.12-1
+- added safety symlink for yum.conf
+
+* Wed Feb 7 2007 Clark Williams <williams@redhat.com> - 0.6.11-1
+- added error() calls to print command output on failed commands
+
+* Tue Feb 6 2007 Clark Williams <williams@redhat.com> - 0.6.11-1
+- added installdeps command for long-term chroot management
+
+* Mon Jan 8 2007 Clark Williams <williams@redhat.com> - 0.6.10-1
- Added Josh Boyer's EPEL config files
-* Wed Jan 3 2007 Clark Williams <williams@redhat.com>
-- Merged mock-0.6 BZ fixes into head
+* Tue Nov 21 2006 Clark Williams <williams@redhat.com> - 0.6.9-1
+- applied Eric Work's patch to fix defaults vs. command line option problem
+ (BZ 215168)
+- use /etc/mock/defaults.cfg if --configdir specified and no defaults found
+ in the specified configdir
+ (BZ 209407)
+- applied Jesse Keatings patch for arch specifi config files
+ (BZ 213516)
+
+* Mon Oct 30 2006 Clark Williams <williams@redhat.com> - 0.6.8-1
+- respun tarballs without buildsys rpms
+
+* Mon Oct 30 2006 Clark Williams <williams@redhat.com> - 0.6.7-1
+- updated for FC6 release
+
+* Sat Oct 21 2006 Clark Williams <williams@redhat.com> - 0.6.6-1
+- bumped version to 0.6.6 (fixed tarball problem)
-* Fri Sep 8 2006 Clark Williams <williams@redhat.com> - 0.7.1-1
-- Change mock.py to /usr/libexec
+* Mon Sep 11 2006 Clark Williams <williams@redhat.com> - 0.6.5-1
+- changed version number for patch from Karanbir Singh
+ (rpm workaround on CentOS 4.4)
-* Wed Aug 16 2006 Clark Williams <williams@redhat.com> - 0.7-2
-- Added buildsys-build.spec to docs
+* Tue Aug 29 2006 Clark Williams <williams@redhat.com> - 0.6.3-1
+- changed version number to indicate fix for bz 204051
+
+* Tue Aug 29 2006 Clark Williams <williams@redhat.com> - 0.6.2-2
+- bumped revision for bz 204051
+
+* Wed Aug 23 2006 Clark Williams <williams@redhat.com> - 0.6.2-1
+- Updated README
+- Fixed link problem in etc/Makefile
+- Bumped version number
+
+* Wed Aug 16 2006 Clark Williams <williams@redhat.com>
+- Added buildsys-build specfile to docs
- Added disttag
- Bumped release number
-* Wed Jun 28 2006 Clark Williams <williams@redhat.com> - 0.7-1
-- updated version to 0.7
-- removed /usr/sbin/mock-helper
-- added /usr/bin/mock launcher
-
* Wed Jun 7 2006 Seth Vidal <skvidal at linux.duke.edu>
- version update