summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMichael E Brown <mebrown@michaels-house.net>2007-10-19 03:36:37 -0500
committerMichael E Brown <mebrown@michaels-house.net>2007-10-19 03:36:37 -0500
commitb993e048e4eb10d1ac8d2529b5b86510a0f0e132 (patch)
treee106dba6fa826876d73c3c7909cf03474a8a42e5 /Makefile.am
parent445c5f26ed1f6109e91441e644ac9f544494d3e6 (diff)
downloadmock-b993e048e4eb10d1ac8d2529b5b86510a0f0e132.tar.gz
mock-b993e048e4eb10d1ac8d2529b5b86510a0f0e132.tar.xz
mock-b993e048e4eb10d1ac8d2529b5b86510a0f0e132.zip
loathe autoconf. finally fix distcheck and 'make distclean' removes src/mock.py problem.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 3 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index 8b9ab70..8f4ffb6 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -50,11 +50,10 @@ pkgpython_PYTHON = \
src/py-libs/trace_decorator.py \
src/py-libs/uid.py
- # indent a space to get around automake
- ifneq ($(top_builddir),$(top_srcdir))
+if BLD_SRC_DIFFERENT
$(top_builddir)/src/mock.py: $(top_srcdir)/src/mock.py
- CLEANFILES=$(top_builddir)/src/mock.py
- endif
+ CLEANFILES+=$(top_builddir)/src/mock.py
+endif
src/mock.py: Makefile
echo Updating $@, current pwd: $$(pwd)