summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid Cantrell <dcantrell@redhat.com>2010-01-06 10:54:03 -1000
committerDavid Cantrell <dcantrell@redhat.com>2010-01-07 08:12:45 -1000
commit37f2d59591ca34bf0643552b5735b9581320df50 (patch)
tree052a5d78afadb8ea09526ab257defc19aa871eec /configure.ac
parent857a926d32d9007e5bd6b528d8606f840b4afb83 (diff)
downloadanaconda-37f2d59591ca34bf0643552b5735b9581320df50.tar.gz
anaconda-37f2d59591ca34bf0643552b5735b9581320df50.tar.xz
anaconda-37f2d59591ca34bf0643552b5735b9581320df50.zip
Add configuration option to enable/disable IPv6 support.
Default is IPv6 is enabled, but people can pass --disable-ipv6 to the configure script to disable the IPv6 bits in loader.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 49b0cb9c1..184da73d3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -171,6 +171,16 @@ if test x$selinux = xyes ; then
AC_SUBST(NFS_CFLAGS, [-DHAVE_NFS])
fi
+# IPv6 support can be enabled or disabled
+AC_ARG_ENABLE(ipv6,
+ AC_HELP_STRING([--enable-ipv6],
+ [enable IPv6 support (default is yes)]),
+ [ipv6=$enableval],
+ [ipv6=yes])
+if test x$ipv6 = xyes ; then
+ AC_SUBST(IPV6_CFLAGS, [-DENABLE_IPV6])
+fi
+
# Add remaining compiler flags we want to use
CFLAGS="$CFLAGS -Wall -Werror -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE"