summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid Cantrell <dcantrell@redhat.com>2009-11-16 19:00:52 -1000
committerDavid Cantrell <dcantrell@redhat.com>2009-11-18 14:42:13 -1000
commit3520edec88cd52222b02aea1a7e3a91863e06a85 (patch)
tree05b9627f1e582a3928146e086a621232296a5227 /configure.ac
parent5a29882c8c85d94d7cc4705f719512f59e48bb24 (diff)
downloadanaconda-3520edec88cd52222b02aea1a7e3a91863e06a85.tar.gz
anaconda-3520edec88cd52222b02aea1a7e3a91863e06a85.tar.xz
anaconda-3520edec88cd52222b02aea1a7e3a91863e06a85.zip
Replace all popt use with glib's option parsing code.
We have glib for other things, so we can use it for option parsing and dump another library dependency.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 1 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 25af0c24e..8162b86ee 100644
--- a/configure.ac
+++ b/configure.ac
@@ -70,10 +70,6 @@ AC_CHECK_LIB([newt], [newtInit],
[AC_SUBST(NEWT_LIBS, [-lnewt])],
[AC_MSG_FAILURE([*** libnewt not usable.])])
-AC_CHECK_LIB([popt], [poptGetContext],
- [AC_SUBST(POPT_LIBS, [-lpopt])],
- [AC_MSG_FAILURE([*** libpopt not usable.])])
-
AC_CHECK_LIB([slang], [SLang_get_int_size],
[AC_SUBST(SLANG_LIBS, [-lslang])],
[AC_MSG_FAILURE([*** libslang not usable.])])
@@ -132,6 +128,7 @@ AM_CHECK_PYTHON_HEADERS(,[AC_MSG_ERROR(could not find Python headers or library)
# Check for libraries we need that provide pkg-config scripts
PKG_PROG_PKG_CONFIG([0.23])
+PKG_CHECK_MODULES([GLIB], [glib-2.0 >= 2.16.1])
PKG_CHECK_MODULES([GTK_X11], [gtk+-x11-2.0 >= 2.16.1])
PKG_CHECK_MODULES([GDK], [gdk-2.0 >= 2.16.1])
PKG_CHECK_MODULES([NETWORKMANAGER], [NetworkManager >= 0.7.1])