summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorChris Lumens <clumens@redhat.com>2009-07-02 12:50:48 -0400
committerChris Lumens <clumens@redhat.com>2009-07-02 12:50:48 -0400
commit8bbbea582deaa7cb653530ee35b0c30ddc44de32 (patch)
tree37ee417b8bb27fc3240d22bc330d89900687dccb /Makefile.am
parentac7f54e655881044eb11187a10158ac791fa9890 (diff)
downloadanaconda-8bbbea582deaa7cb653530ee35b0c30ddc44de32.tar.gz
anaconda-8bbbea582deaa7cb653530ee35b0c30ddc44de32.tar.xz
anaconda-8bbbea582deaa7cb653530ee35b0c30ddc44de32.zip
Fix "make bumpver" for two digit version numbers.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 67e4e2f3a..138ceabce 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -112,8 +112,8 @@ rpmlog:
@echo
bumpver:
- @NEWSUBVER=$$((`echo $(PACKAGE_VERSION) |cut -d . -f 4` + 1)) ; \
- NEWVERSION=`echo $(PACKAGE_VERSION).$$NEWSUBVER |cut -d . -f 1-3,5` ; \
+ @NEWSUBVER=$$((`echo $(PACKAGE_VERSION) |cut -d . -f 2` + 1)) ; \
+ NEWVERSION=`echo $(PACKAGE_VERSION).$$NEWSUBVER |cut -d . -f 1,3` ; \
DATELINE="* `date "+%a %b %d %Y"` `git config user.name` <`git config user.email`> - $$NEWVERSION-1" ; \
cl=`grep -n %changelog anaconda.spec.in |cut -d : -f 1` ; \
tail --lines=+$$(($$cl + 1)) anaconda.spec.in > speclog ; \