summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorDavid Cantrell <dcantrell@redhat.com>2009-07-20 10:11:03 -1000
committerDavid Cantrell <dcantrell@redhat.com>2009-07-22 15:17:40 -1000
commit73c5610adfb315d49f52a01a0a5808d4a198388b (patch)
tree49b9f7e51afb36fc0803d2e99eed206f57994762 /Makefile.am
parenta62ef457380ec9cfd589994e82752d74820038aa (diff)
downloadanaconda-73c5610adfb315d49f52a01a0a5808d4a198388b.tar.gz
anaconda-73c5610adfb315d49f52a01a0a5808d4a198388b.tar.xz
anaconda-73c5610adfb315d49f52a01a0a5808d4a198388b.zip
Add scripts/makeupdates to generate updates.img files.
Move the contents of the 'make updates' target to scripts/makeupdates. Make the recompilation of the _isys module be conditional (if you want to do that, either run 'make updates' as you have been or pass -c to scripts/makeupdates). Running makeupdates without -c will generate an updates.img with just the changed Python files.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am36
1 files changed, 3 insertions, 33 deletions
diff --git a/Makefile.am b/Makefile.am
index 572dfe86a..c2c657702 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -136,43 +136,13 @@ install-buildrequires:
# created. By default, the updates subdirectory is removed after the
# image is made, but if you want to keep it around, run:
# make updates.img KEEP=y
-# And since shell is both stupid and amusing, I only match the first
-# character to be a 'y' or 'Y', so you can do:
-# make updates.img KEEP=yosemite
-# Ahh, shell.
updates:
- @if [ ! -d updates-img ]; then \
- mkdir updates-img ; \
- fi ; \
- build_isys="$$(git diff --stat $(ARCHIVE_TAG) isys | grep " | " | cut -d ' ' -f 2 | egrep "(Makefile|\.h|\.c)$$")" ; \
- git diff --stat $(ARCHIVE_TAG) | grep " | " | \
- grep -v "\.spec" | grep -v "Makefile" | grep -v "\.c\ " | \
- grep -v "\.h" | grep -v "\.sh" | grep -v "configure\.ac" | \
- while read sourcefile stuff ; do \
- dn="$$(echo $$sourcefile | cut -d '/' -f 1)" ; \
- case $$dn in \
- installclasses|storage|booty) \
- rm -rf updates-img/$$dn ; \
- cp -a $$dn updates-img ; \
- find updates-img/$$dn -type f | egrep 'Makefile|\.pyc' | xargs rm -f ;; \
- loader|po|scripts|command-stubs|tests|bootdisk|docs|fonts|utils|gptsync) \
- continue ;; \
- *) \
- cp -a $$sourcefile updates-img ;; \
- esac ; \
- done ; \
- if [ ! -z "$$build_isys" ]; then \
- make -C isys ; \
- cp isys/_isys.so updates-img ; \
- fi ; \
- cd updates-img ; \
- echo -n "Creating updates.img..." ; \
- ( find . | cpio -c -o | gzip -9c ) > ../updates.img ; \
- cd .. ; \
+ @opts="-c" ; \
keep="$$(echo $(KEEP) | cut -c1 | tr [a-z] [A-Z])" ; \
if [ ! "$$keep" = "Y" ]; then \
- rm -rf updates-img ; \
+ opts="${opts} -k" ; \
fi
+ scripts/makeupdates ${opts}
# DEPRECATED TARGETS:
archive-no-tag: dist