summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorDavid Cantrell <dcantrell@redhat.com>2009-10-28 11:56:32 -1000
committerDavid Cantrell <dcantrell@redhat.com>2009-10-30 12:53:09 -1000
commit55396fbb36523876e08cf84f214d769b56bebec8 (patch)
treeec12cdcfae398c6188d72590d11b154e447f6dc3 /Makefile.am
parent6812d9347ad3353f7ff857d53a786a37327f8451 (diff)
downloadanaconda-55396fbb36523876e08cf84f214d769b56bebec8.tar.gz
anaconda-55396fbb36523876e08cf84f214d769b56bebec8.tar.xz
anaconda-55396fbb36523876e08cf84f214d769b56bebec8.zip
Clear pot and po updates after a 'make release' or 'make archive'.
These are updated by msgfmt, but leave the po files in the repository as is since they are updated by an external project. We'll keep the pot file up to date, but that happens at 'make bumpver'. Since msgfmt generates new po files for the release tarball, we need to reset all of these files after a 'make release' or 'make archive'.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 79b43e581..cf11faa21 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -94,6 +94,8 @@ scratch:
archive:
$(MAKE) tag
$(MAKE) dist
+ git checkout -- po/$(PACKAGE_NAME).pot
+ ( cd po ; for f in *.po ; do git checkout -- $$f 2>/dev/null ; done )
release: archive