summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorDavid Cantrell <dcantrell@redhat.com>2009-08-27 14:58:26 -1000
committerDavid Cantrell <dcantrell@redhat.com>2009-09-02 09:18:44 -1000
commit328236b01f16abdc7893f2be93cea2c93b7b13d8 (patch)
tree480e8a8f08477d5a02ac3a98b70450fa3441e863 /Makefile.am
parent76381b4cfafd4885a321525ef9968c26e6dcee58 (diff)
downloadanaconda-328236b01f16abdc7893f2be93cea2c93b7b13d8.tar.gz
anaconda-328236b01f16abdc7893f2be93cea2c93b7b13d8.tar.xz
anaconda-328236b01f16abdc7893f2be93cea2c93b7b13d8.zip
Add some silent make support for sed, mkctype, and other commands.
Match up to the silent make thing we have by default now.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 89800ef25..ebe6909d1 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -68,8 +68,12 @@ PYCHECKERPATH = isys:textw:iw:installclasses:/usr/share/system-config-date
PYCHECKEROPTS = -F pycheckrc-for-anaconda
ARCHIVE_TAG = $(PACKAGE_NAME)-$(PACKAGE_VERSION)-$(PACKAGE_RELEASE)
+sed_verbose = $(sed_verbose_$(V))
+sed_verbose_ = $(sed_verbose_$(AM_DEFAULT_VERBOSITY))
+sed_verbose_0 = @echo " SED "$@;
+
$(PACKAGE_NAME).spec: $(PACKAGE_NAME).spec.in
- sed -e 's/#VERSION#/$(PACKAGE_VERSION)/' < $< > $@
+ $(sed_verbose)sed -e 's/#VERSION#/$(PACKAGE_VERSION)/' < $< > $@
lang-names: lang-table
PYTHONPATH="." $(PYTHON) scripts/getlangnames.py > lang-names