summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorDavid Cantrell <dcantrell@redhat.com>2009-08-18 16:04:38 -1000
committerDavid Cantrell <dcantrell@redhat.com>2009-08-19 15:09:21 -1000
commit0893244dbdb3e2faada5224bf49458b61389ba34 (patch)
tree6e758adcf769d8027996f5a749a8142bbd7a020d /Makefile.am
parent96cf61f06b6139be619ac114599428be367bc23e (diff)
downloadanaconda-0893244dbdb3e2faada5224bf49458b61389ba34.tar.gz
anaconda-0893244dbdb3e2faada5224bf49458b61389ba34.tar.xz
anaconda-0893244dbdb3e2faada5224bf49458b61389ba34.zip
Fix updates target to honor KEEP variable correctly.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 4 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index 5a5f04730..89800ef25 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -136,10 +136,10 @@ install-buildrequires:
updates:
@opts="-c" ; \
keep="$$(echo $(KEEP) | cut -c1 | tr [a-z] [A-Z])" ; \
- if [ ! "$$keep" = "Y" ]; then \
- opts="${opts} -k" ; \
- fi
- scripts/makeupdates ${opts}
+ if [ "$${keep}" = "Y" ]; then \
+ opts="$${opts} -k" ; \
+ fi ; \
+ scripts/makeupdates $${opts}
# DEPRECATED TARGETS:
archive-no-tag: dist