summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorDavid Cantrell <dcantrell@redhat.com>2009-10-20 11:49:03 -1000
committerDavid Cantrell <dcantrell@redhat.com>2009-10-20 13:09:16 -1000
commit011e02e93bceddf6e3333c48e1f888d6cc307994 (patch)
tree02e90b0003229739032c6a8ee60df7cf4cddaa90 /Makefile.am
parent700d030c5476b87526828e82005bbf31bbacff0a (diff)
downloadanaconda-011e02e93bceddf6e3333c48e1f888d6cc307994.tar.gz
anaconda-011e02e93bceddf6e3333c48e1f888d6cc307994.tar.xz
anaconda-011e02e93bceddf6e3333c48e1f888d6cc307994.zip
Handle more than x.y version numbers in 'make bumpver'.
For the rhel6-branch, we now have an x.y.z version number since it was branched from f12-branch. The bumpver target needs to handle the extra .z component.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index e06a7ce01..79b43e581 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -117,8 +117,10 @@ rpmlog:
grep -v -- "- Sending translation for "
bumpver:
- @NEWSUBVER=$$((`echo $(PACKAGE_VERSION) |cut -d . -f 2` + 1)) ; \
- NEWVERSION=`echo $(PACKAGE_VERSION).$$NEWSUBVER |cut -d . -f 1,3` ; \
+ @LAST=$$(echo $(PACKAGE_VERSION) | grep "\." -o | wc -l) ; \
+ FIELD=$$(($${LAST} + 1)) ; \
+ NEWSUBVER=$$((`echo $(PACKAGE_VERSION) | cut -d . -f $${FIELD}` + 1)) ; \
+ NEWVERSION="`echo $(PACKAGE_VERSION) | cut -d . -f 1-$${LAST}`.$$NEWSUBVER" ; \
DATELINE="* `date "+%a %b %d %Y"` `git config user.name` <`git config user.email`> - $$NEWVERSION-1" ; \
cl=`grep -n %changelog anaconda.spec.in |cut -d : -f 1` ; \
tail --lines=+$$(($$cl + 1)) anaconda.spec.in > speclog ; \