summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 5882992..3ea4a45 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -53,11 +53,15 @@ if (DEFINED DEFAULT_LINK_FLAGS)
endif()
install(TARGETS socket_wrapper_noop
+ EXPORT socket_wrapper_noop-config
RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR}
LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}
ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR}
)
+install(EXPORT socket_wrapper_noop-config
+ DESTINATION ${CMAKE_INSTALL_LIBDIR}/cmake/socket_wrapper)
+
install(
FILES
${CMAKE_CURRENT_SOURCE_DIR}/socket_wrapper.h