summaryrefslogtreecommitdiffstats
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorMichael Adam <obnox@samba.org>2016-09-22 03:53:27 +0200
committerAndreas Schneider <asn@samba.org>2018-05-02 16:31:42 +0200
commita5c08518e985bd3f0cb274c274c034be37fa5629 (patch)
tree7bd9c69acba66db9b9686bc3d66cf8a251659e80 /tests/CMakeLists.txt
parentb6909fc91d5d16ced108700cbd5cd8a13481a6c4 (diff)
downloadsocket_wrapper-a5c08518e985bd3f0cb274c274c034be37fa5629.tar.gz
socket_wrapper-a5c08518e985bd3f0cb274c274c034be37fa5629.tar.xz
socket_wrapper-a5c08518e985bd3f0cb274c274c034be37fa5629.zip
tests: Add new test to check mutex lock contention
Signed-off-by: Michael Adam <obnox@samba.org> Reviewed-by: Andreas Schneider <asn@samba.org>
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index 836a5e2..0887a01 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -37,7 +37,8 @@ set(SWRAP_TESTS
test_swrap_unit
test_max_sockets
test_close_failure
- test_fork_thread_deadlock)
+ test_fork_thread_deadlock
+ test_thread_sockets)
if (HAVE_STRUCT_MSGHDR_MSG_CONTROL)
set(SWRAP_TESTS ${SWRAP_TESTS} test_sendmsg_recvmsg_fd)