summaryrefslogtreecommitdiffstats
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorAnoop C S <anoopcs@samba.org>2020-07-23 15:59:29 +0530
committerAndreas Schneider <asn@samba.org>2021-02-02 10:23:33 +0100
commit66a5bef7f9aac4d70124bc8efec72dcd434c660a (patch)
tree895b614196a4dc1ad8d6a42bd4045dc260a47681 /tests/CMakeLists.txt
parent650115f1b4ed2fd4aa7d65ce7578bc919e0601f4 (diff)
downloadsocket_wrapper-66a5bef7f9aac4d70124bc8efec72dcd434c660a.tar.gz
socket_wrapper-66a5bef7f9aac4d70124bc8efec72dcd434c660a.tar.xz
socket_wrapper-66a5bef7f9aac4d70124bc8efec72dcd434c660a.zip
tests: Add test for socket_wrapper fd-passing support
Signed-off-by: Anoop C S <anoopcs@samba.org> Reviewed-by: Stefan Metzmacher <metze@samba.org> Reviewed-by: Andreas Schneider <asn@samba.org>
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index 72cda71..fce69e4 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -61,7 +61,7 @@ set(SWRAP_TESTS
${SWRAP_THREADED_TESTS})
if (HAVE_STRUCT_MSGHDR_MSG_CONTROL)
- set(SWRAP_TESTS ${SWRAP_TESTS} test_sendmsg_recvmsg_fd)
+ set(SWRAP_TESTS ${SWRAP_TESTS} test_sendmsg_recvmsg_fd test_echo_tcp_sendmsg_recvmsg_fd)
endif (HAVE_STRUCT_MSGHDR_MSG_CONTROL)
function(ADD_CMOCKA_TEST_ENVIRONMENT _TEST_NAME)
@@ -116,6 +116,10 @@ foreach(_SWRAP_TEST ${SWRAP_TESTS})
add_cmocka_test_environment(${_SWRAP_TEST})
endforeach()
+if (HAVE_STRUCT_MSGHDR_MSG_CONTROL)
+ set_tests_properties(test_echo_tcp_sendmsg_recvmsg_fd PROPERTIES WILL_FAIL TRUE)
+endif (HAVE_STRUCT_MSGHDR_MSG_CONTROL)
+
if (HELGRIND_TESTING)
find_program(VALGRIND_EXECUTABLE valgrind)
if (VALGRIND_EXECUTABLE)