summaryrefslogtreecommitdiffstats
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorAndreas Schneider <asn@samba.org>2017-11-28 15:41:05 +0100
committerAndreas Schneider <asn@samba.org>2017-12-04 12:23:47 +0100
commit3f804113608f0c2f04a8212fbacf569b67dd0a19 (patch)
treeb90a59dadb65e40420efd4b8e0d12424c098020d /tests/CMakeLists.txt
parent3547fdfc094f4588375cb7b1716461f8f328b643 (diff)
downloadsocket_wrapper-3f804113608f0c2f04a8212fbacf569b67dd0a19.tar.gz
socket_wrapper-3f804113608f0c2f04a8212fbacf569b67dd0a19.tar.xz
socket_wrapper-3f804113608f0c2f04a8212fbacf569b67dd0a19.zip
tests: Add a thread deadlock reproducer
Signed-off-by: Andreas Schneider <asn@samba.org> Reviewed-by: Stefan Metzmacher <metze@samba.org>
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt8
1 files changed, 7 insertions, 1 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index 32a457e..b86cc84 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -37,7 +37,8 @@ set(SWRAP_TESTS
test_echo_udp_sendmsg_recvmsg
test_swrap_unit
test_max_sockets
- test_close_failure)
+ test_close_failure
+ test_fork_thread_deadlock)
if (HAVE_STRUCT_MSGHDR_MSG_CONTROL)
set(SWRAP_TESTS ${SWRAP_TESTS} test_sendmsg_recvmsg_fd)
@@ -60,3 +61,8 @@ foreach(_SWRAP_TEST ${SWRAP_TESTS})
ENVIRONMENT LD_PRELOAD=${SOCKET_WRAPPER_LOCATION})
endif()
endforeach()
+
+# test_fork_pthread
+add_library(thread_deadlock SHARED thread_deadlock.c)
+target_link_libraries(thread_deadlock ${CMAKE_THREAD_LIBS_INIT})
+target_link_libraries(test_fork_thread_deadlock thread_deadlock)