summaryrefslogtreecommitdiffstats
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorMichael Adam <obnox@samba.org>2016-09-18 20:28:06 +0200
committerMichael Adam <obnox@samba.org>2016-10-20 11:21:53 +0200
commit201811dc614a4787482c3bb2fa14f47112a05a34 (patch)
tree1dfbae0c2d953f1631a2dd45d61ffdb9615e4896 /tests/CMakeLists.txt
parent3507e186d08fa8170a3499c9e69a49aa60ff9dcd (diff)
downloadsocket_wrapper-201811dc614a4787482c3bb2fa14f47112a05a34.tar.gz
socket_wrapper-201811dc614a4787482c3bb2fa14f47112a05a34.tar.xz
socket_wrapper-201811dc614a4787482c3bb2fa14f47112a05a34.zip
cmake: Link pthread library headers
Signed-off-by: Michael Adam <obnox@samba.org> Reviewed-by: Andreas Schneider <asn@samba.org>
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index aa5b183..9292b40 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -16,7 +16,8 @@ target_link_libraries(echo_srv ${SWRAP_REQUIRED_LIBRARIES})
add_library(${TORTURE_LIBRARY} STATIC torture.c)
target_link_libraries(${TORTURE_LIBRARY}
${CMOCKA_LIBRARY}
- ${SWRAP_REQUIRED_LIBRARIES})
+ ${SWRAP_REQUIRED_LIBRARIES}
+ ${CMAKE_THREAD_LIBS_INIT})
set(SWRAP_TESTS
test_ioctl