summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules31
1 files changed, 31 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..81db93e
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,31 @@
+#!/usr/bin/make -f
+# -*- makefile -*-
+
+clean:
+ dh_testdir
+ dh_testroot
+ dh_clean
+
+build:
+
+install: build
+ dh_testdir
+ dh_testroot
+ dh_clean -k
+ dh_installdirs
+ make install prefix=/usr DESTDIR=$(CURDIR)/debian/tmp
+
+binary: install
+ dh_testdir
+ dh_testroot
+ dh_install --autodest debian/tmp/*
+ dh_installdocs
+ dh_installexamples examples/example.sh
+ dh_compress
+ dh_fixperms
+ dh_installdeb
+ dh_gencontrol
+ dh_md5sums
+ dh_builddeb
+
+.PHONY: binary install