summaryrefslogtreecommitdiffstats
path: root/hyperkitty.spec
diff options
context:
space:
mode:
authorAurélien Bompard <aurelien@bompard.org>2013-02-19 12:27:35 +0100
committerAurélien Bompard <aurelien@bompard.org>2013-02-19 12:45:34 +0100
commit838660b2faf2f419838dec591214c533323bb332 (patch)
tree10ef0830942fd19ef650305ecf3b2bac64cf6a8f /hyperkitty.spec
parent4889bb7371b0fc8ce427aa761be00c6b1ac3d212 (diff)
downloadhyperkitty-838660b2faf2f419838dec591214c533323bb332.tar.gz
hyperkitty-838660b2faf2f419838dec591214c533323bb332.tar.xz
hyperkitty-838660b2faf2f419838dec591214c533323bb332.zip
Fix unit tests
Diffstat (limited to 'hyperkitty.spec')
-rw-r--r--hyperkitty.spec6
1 files changed, 4 insertions, 2 deletions
diff --git a/hyperkitty.spec b/hyperkitty.spec
index ac0bb25..529128f 100644
--- a/hyperkitty.spec
+++ b/hyperkitty.spec
@@ -38,6 +38,7 @@ The documentation can be browsed online at https://hyperkitty.readthedocs.org .
%setup -q -n %{pypi_name}-%{version} -a 1
# Remove bundled egg-info
rm -rf %{pypi_name}.egg-info
+mv hyperkitty_standalone-%{version} hyperkitty_standalone
# remove shebang on manage.py
sed -i -e '1d' hyperkitty_standalone/manage.py
# remove executable permissions on wsgi.py
@@ -87,8 +88,9 @@ touch --reference hyperkitty_standalone/settings.py \
%check
-%{__python} %{_bindir}/django-admin test --pythonpath=`pwd` \
- --settings=hyperkitty.tests_conf.settings_tests hyperkitty
+touch hyperkitty_standalone/__init__.py
+%{__python} hyperkitty_standalone/manage.py test hyperkitty
+rm -f hyperkitty_standalone/__init__.py
%post