summaryrefslogtreecommitdiffstats
path: root/yp/Makefile.am
diff options
context:
space:
mode:
authorNalin Dahyabhai <nalin@dahyabhai.net>2011-05-13 14:10:38 -0400
committerNalin Dahyabhai <nalin@dahyabhai.net>2011-05-13 14:24:07 -0400
commitc96a766171b601d5061b566d5da3794d9df354d2 (patch)
tree965c207f52ab4087f2a880fe7b2866cb99623790 /yp/Makefile.am
parente5698d42c039b6d7d33af94eb1ee7d4c044625df (diff)
downloadslapi-nis-c96a766171b601d5061b566d5da3794d9df354d2.tar.gz
slapi-nis-c96a766171b601d5061b566d5da3794d9df354d2.tar.xz
slapi-nis-c96a766171b601d5061b566d5da3794d9df354d2.zip
- don't assume that libc will provide yp headers -- build them ourselves
Diffstat (limited to 'yp/Makefile.am')
-rw-r--r--yp/Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/yp/Makefile.am b/yp/Makefile.am
new file mode 100644
index 0000000..b24e958
--- /dev/null
+++ b/yp/Makefile.am
@@ -0,0 +1,11 @@
+EXTRA_FILES = yp.x
+CLEANFILES = yp.h yp_xdr.c yp_clnt.c
+
+all: $(CLEANFILES)
+
+yp.h: yp.x
+ $(RPCGEN) -h -o $@ $^
+yp_xdr.c: yp.x
+ $(RPCGEN) -c -o $@ $^
+yp_clnt.c: yp.x
+ $(RPCGEN) -l -o $@ $^