summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorNalin Dahyabhai <nalin.dahyabhai@pobox.com>2008-06-03 16:40:02 -0400
committerNalin Dahyabhai <nalin.dahyabhai@pobox.com>2008-06-03 16:40:02 -0400
commit4ecac0089c5daf1a43b9d19fc09f045d0569866d (patch)
treec350493dc71fae00c378079d24a42bff223c3c46 /src/Makefile.am
parenteec97835e2ddceb599070ac61109278b9576092f (diff)
downloadslapi-nis-4ecac0089c5daf1a43b9d19fc09f045d0569866d.tar.gz
slapi-nis-4ecac0089c5daf1a43b9d19fc09f045d0569866d.tar.xz
slapi-nis-4ecac0089c5daf1a43b9d19fc09f045d0569866d.zip
- uncomment things in the design doc that have been done
- don't lose source header and doc files in the 'dist' target - don't explicitly link with libpthread unless we need to do so
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am24
1 files changed, 20 insertions, 4 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 77179bb..27d9e74 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,27 +1,43 @@
AM_CFLAGS = $(RUNTIME_CFLAGS)
AM_LDFLAGS = -module -avoid-version -export-symbols-regex nis_plugin_init
+LIBPTHREAD = @LIBPTHREAD@
LIBWRAP = @LIBWRAP@
plugindir = $(libdir)/dirsrv/plugins
+dist_noinst_SCRIPTS = ypmaplist.py
plugin_LTLIBRARIES = nis-plugin.la
nis_plugin_la_SOURCES = \
backend.c \
+ backend.h \
+ defaults.c \
+ defaults.h \
dispatch.c \
+ dispatch.h \
format.c \
- defaults.c \
+ format.h \
map.c \
+ map.h \
nis.c \
+ nis.h \
plugin.c \
+ plugin.h \
portmap.c \
- wrap.c
-nis_plugin_la_LIBADD = $(RUNTIME_LIBS) $(LIBWRAP) -lnsl -lpthread
+ portmap.h \
+ wrap.c \
+ wrap.h
+nis_plugin_la_LIBADD = $(RUNTIME_LIBS) $(LIBWRAP) -lnsl $(LIBPTHREAD)
noinst_LTLIBRARIES = dummy-nis-plugin.la
dummy_nis_plugin_la_SOURCES = \
dispatch.c \
+ dispatch.h \
dummymap.c \
+ map.h \
nis.c \
+ nis.h \
plugin.c \
- portmap.c
+ plugin.h \
+ portmap.c \
+ portmap.h
dummy_nis_plugin_la_LIBADD = $(RUNTIME_LIBS) -lnsl -lpthread