summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorNalin Dahyabhai <nalin.dahyabhai@pobox.com>2009-02-11 18:18:59 -0500
committerNalin Dahyabhai <nalin.dahyabhai@pobox.com>2009-02-11 18:18:59 -0500
commit48b86df0785be9a006a4441d1a26846da7d9b4b3 (patch)
tree3e79b1daa530572db3e5e8f5815c05dae83a64b1 /src/Makefile.am
parente8c9eb7a3f17897472b5aa89fab4b5869418800f (diff)
downloadslapi-nis-48b86df0785be9a006a4441d1a26846da7d9b4b3.tar.gz
slapi-nis-48b86df0785be9a006a4441d1a26846da7d9b4b3.tar.xz
slapi-nis-48b86df0785be9a006a4441d1a26846da7d9b4b3.zip
- use tirpc cflags if they're set, link with libtirpc if we found it,
always build the portmap example client
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 132a549..9871f99 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -18,6 +18,11 @@ sbin_PROGRAMS = nisserver-plugin-defs
nisserver_plugin_defs_CFLAGS = $(AM_CFLAGS) -DDEFS_NIS_MAIN
nisserver_plugin_defs_SOURCES = defs-nis.c
+noinst_PROGRAMS = portmap
+portmap_CFLAGS = $(AM_CFLAGS) -DPORTMAP_MAIN
+portmap_SOURCES = portmap.c
+
+nisserver_plugin_la_CFLAGS = $(AM_CFLAGS) $(TIRPC_CFLAGS)
nisserver_plugin_la_SOURCES = \
back-nis.c \
backend.h \
@@ -39,7 +44,7 @@ nisserver_plugin_la_SOURCES = \
portmap.h \
wrap.c \
wrap.h
-nisserver_plugin_la_LIBADD = $(RUNTIME_LIBS) $(LIBWRAP) -lnsl $(LIBPTHREAD)
+nisserver_plugin_la_LIBADD = $(RUNTIME_LIBS) $(TIRPC_LIBS) $(LIBWRAP) -lnsl $(LIBPTHREAD)
schemacompat_plugin_la_SOURCES = \
back-sch.c \