summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorAlexander Bokovoy <abokovoy@redhat.com>2013-07-31 14:44:37 +0300
committerNalin Dahyabhai <nalin@dahyabhai.net>2013-08-07 11:34:49 -0400
commit195ced520420ecd77f907b7a6513dd0448e9ae8f (patch)
tree1d84c74eb2b37cac4cd6b66db4414b9859d1ac18 /src/Makefile.am
parente0815d7416bba2097fc2b94ab92a3c0ea3a4f338 (diff)
downloadslapi-nis-195ced520420ecd77f907b7a6513dd0448e9ae8f.tar.gz
slapi-nis-195ced520420ecd77f907b7a6513dd0448e9ae8f.tar.xz
slapi-nis-195ced520420ecd77f907b7a6513dd0448e9ae8f.zip
src/Makefile.am: add back-sch-nss.c and back-sch-pam.c to build
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 0563171..5bb8dde 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -65,6 +65,16 @@ schemacompat_plugin_la_SOURCES = \
wrap.h
schemacompat_plugin_la_LIBADD = $(LDAP_LIBS) $(RUNTIME_LIBS) $(LIBPTHREAD) $(CONFIGURED_LINK_FLAGS)
+if USE_NSSWITCH
+schemacompat_plugin_la_SOURCES += back-sch-nss.c
+schemacompat_plugin_la_LIBADD += $(SSS_NSS_IDMAP_LIBS)
+endif
+
+if USE_PAM
+schemacompat_plugin_la_SOURCES += back-sch-pam.c
+schemacompat_plugin_la_LIBADD += $(PAM_LIBS)
+endif
+
noinst_LTLIBRARIES = dummy-nis-plugin.la
dummy_nis_plugin_la_SOURCES = \
disp-nis.c \