summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorNalin Dahyabhai <nalin.dahyabhai@pobox.com>2009-02-11 21:29:31 -0500
committerNalin Dahyabhai <nalin.dahyabhai@pobox.com>2009-02-11 21:29:31 -0500
commit13e818b9df6c15076ba9f6d23adaf480c98a6d93 (patch)
tree6b9a4ed69da5bd63509f61b2cc7d2d6c901a334a /src/Makefile.am
parentaa5eba2f69343b33d038ae4441d250cda3f55e0c (diff)
downloadslapi-nis-13e818b9df6c15076ba9f6d23adaf480c98a6d93.tar.gz
slapi-nis-13e818b9df6c15076ba9f6d23adaf480c98a6d93.tar.xz
slapi-nis-13e818b9df6c15076ba9f6d23adaf480c98a6d93.zip
- link with libnsl or libtirpc, not both
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 9871f99..4797259 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,4 +1,4 @@
-AM_CFLAGS = $(RUNTIME_CFLAGS)
+AM_CFLAGS = $(RUNTIME_CFLAGS) $(TIRPC_CFLAGS) $(RPC_CFLAGS)
AM_LDFLAGS = -module -avoid-version -export-symbols-regex '.*_plugin_init'
LIBPTHREAD = @LIBPTHREAD@
LIBWRAP = @LIBWRAP@
@@ -21,8 +21,8 @@ nisserver_plugin_defs_SOURCES = defs-nis.c
noinst_PROGRAMS = portmap
portmap_CFLAGS = $(AM_CFLAGS) -DPORTMAP_MAIN
portmap_SOURCES = portmap.c
+portmap_LDFLAGS = $(RUNTIME_LIBS) $(TIRPC_LIBS) $(LIBWRAP) $(RPC_LIBS) $(LIBPTHREAD)
-nisserver_plugin_la_CFLAGS = $(AM_CFLAGS) $(TIRPC_CFLAGS)
nisserver_plugin_la_SOURCES = \
back-nis.c \
backend.h \
@@ -44,7 +44,7 @@ nisserver_plugin_la_SOURCES = \
portmap.h \
wrap.c \
wrap.h
-nisserver_plugin_la_LIBADD = $(RUNTIME_LIBS) $(TIRPC_LIBS) $(LIBWRAP) -lnsl $(LIBPTHREAD)
+nisserver_plugin_la_LIBADD = $(RUNTIME_LIBS) $(TIRPC_LIBS) $(LIBWRAP) $(RPC_LIBS) $(LIBPTHREAD)
schemacompat_plugin_la_SOURCES = \
back-sch.c \