summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorNalin Dahyabhai <nalin@redhat.com>2012-11-12 13:47:47 -0500
committerNalin Dahyabhai <nalin@redhat.com>2012-11-12 13:47:47 -0500
commitf3f8ea446c04b3ca50a723d007314eba9d21d133 (patch)
tree08dffb8fe14c06f11dd997adffcf23cb1782f3f9 /configure.ac
parentf3107c65d71d2167e9b95ff79a0d75ed5385bb56 (diff)
downloadslapi-nis-f3f8ea446c04b3ca50a723d007314eba9d21d133.tar.gz
slapi-nis-f3f8ea446c04b3ca50a723d007314eba9d21d133.tar.xz
slapi-nis-f3f8ea446c04b3ca50a723d007314eba9d21d133.zip
add test use of betxns
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 18 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 90dba52..47181f5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -481,6 +481,7 @@ TESTS_USE_REFINT=true
TESTS_USE_MEMBEROF=true
TESTS_USE_MANAGED_ENTRIES=true
TESTS_USE_USN=true
+TESTS_USE_BETXN=true
AC_ARG_ENABLE(tests-with-refint,
AS_HELP_STRING([--disable-tests-with-refint],
[skip tests which use the the refint plugin]),
@@ -521,10 +522,27 @@ AC_ARG_ENABLE(tests-with-usn,
TESTS_USE_USN=false
fi,
AC_MSG_RESULT([running tests with usn enabled]))
+AC_ARG_ENABLE(tests-with-betxn,
+ AS_HELP_STRING([--disable-tests-with-betxn],
+ [skip tests which are impacted by betxns]),
+ if test x$enableval = xyes ; then
+ AC_MSG_RESULT([running tests with betxn enabled])
+ else
+ AC_MSG_RESULT([running tests with betxn disabled])
+ TESTS_USE_BETXN=false
+ fi,
+ AC_MSG_RESULT([running tests with betxn enabled]))
AC_SUBST(TESTS_USE_REFINT)
AC_SUBST(TESTS_USE_MEMBEROF)
AC_SUBST(TESTS_USE_MANAGED_ENTRIES)
AC_SUBST(TESTS_USE_USN)
+AC_SUBST(TESTS_USE_BETXN)
+if $TESTS_USE_BETXN ; then
+ TEST_PLUGIN_BETXN_ENABLE_OR_NOT="nsslapd-pluginbetxn: on"
+else
+ TEST_PLUGIN_BETXN_ENABLE_OR_NOT="nsslapd-pluginbetxn: off"
+fi
+AC_SUBST(TEST_PLUGIN_BETXN_ENABLE_OR_NOT)
AC_CONFIG_HEADER(src/config.h)
AC_OUTPUT(Makefile yp/Makefile src/Makefile