summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorNalin Dahyabhai <nalin@redhat.com>2012-11-13 18:08:38 -0500
committerNalin Dahyabhai <nalin@redhat.com>2012-11-13 18:08:38 -0500
commiteaa9c342928e20324f3248e65a37bb344fb0671c (patch)
tree8b0bce386addc0997e19e482abbe7804130b4dde /configure.ac
parent9a926114539a95cfc09e2b6601322072437d9a19 (diff)
downloadslapi-nis-eaa9c342928e20324f3248e65a37bb344fb0671c.tar.gz
slapi-nis-eaa9c342928e20324f3248e65a37bb344fb0671c.tar.xz
slapi-nis-eaa9c342928e20324f3248e65a37bb344fb0671c.zip
show betxn settings in the plugin version
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 13 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index d285b3b..9d639cf 100644
--- a/configure.ac
+++ b/configure.ac
@@ -222,6 +222,19 @@ fi
AC_DEFINE_UNQUOTED(DEFAULT_PLUGIN_USE_BETXNS,$deftransactions,
[Define non-zero if support for backend transactions should be enabled by default.])
+AH_VERBATIM([PACKAGE_VERSION_HAVE_TXNS],
+[
+#ifdef SLAPI_NIS_SUPPORT_BE_TXNS
+#ifdef DEFAULT_PLUGIN_USE_BETXNS
+#define PACKAGE_VERSION_TXNS " (betxns:supported_and_used_by_default)"
+#else
+#define PACKAGE_VERSION_TXNS " (betxns:supported_but_not_used_by_default)"
+#endif
+#else
+#define PACKAGE_VERSION_TXNS " (betxns:not_supported)"
+#endif
+])
+
if test $thread_api = NSPR ; then
AC_DEFINE(USE_NSPR_THREADS,1,[Define to use NSPR threading functions.])
elif test $thread_api = POSIX ; then