summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorNalin Dahyabhai <nalin@redhat.com>2012-01-10 15:00:26 -0500
committerNalin Dahyabhai <nalin@redhat.com>2012-01-10 15:00:26 -0500
commitaa97ed3f671ff1229d26993194afa85468aa77b7 (patch)
treedc1dadb507df0c32737d2cc5e3c961a2f09065ca /configure.ac
parent777314292282904609a3d6541723006dc28325b0 (diff)
downloadslapi-nis-aa97ed3f671ff1229d26993194afa85468aa77b7.tar.gz
slapi-nis-aa97ed3f671ff1229d26993194afa85468aa77b7.tar.xz
slapi-nis-aa97ed3f671ff1229d26993194afa85468aa77b7.zip
- add config snippet for managed-entries and load it by default
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 15 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 9f027c6..3b6a592 100644
--- a/configure.ac
+++ b/configure.ac
@@ -407,6 +407,7 @@ AC_SUBST(CONFIGURED_LINK_FLAGS)
TESTS_USE_REFINT=true
TESTS_USE_MEMBEROF=true
+TESTS_USE_MANAGED_ENTRIES=true
AC_ARG_ENABLE(tests-with-refint,
AS_HELP_STRING([--disable-tests-with-refint],
[skip tests which use the the refint plugin]),
@@ -427,13 +428,26 @@ AC_ARG_ENABLE(tests-with-memberof,
TESTS_USE_MEMBEROF=false
fi,
AC_MSG_RESULT([running tests with memberof enabled]))
+AC_ARG_ENABLE(tests-with-managed-entries,
+ AS_HELP_STRING([--disable-tests-with-managed-entries],
+ [skip tests which are impacted by the managed entries plugin]),
+ if test x$enableval = xyes ; then
+ AC_MSG_RESULT([running tests with managed entries enabled])
+ else
+ AC_MSG_RESULT([running tests with managed entries disabled])
+ TESTS_USE_MANAGED_ENTRIES=false
+ fi,
+ AC_MSG_RESULT([running tests with managed entries enabled]))
AC_SUBST(TESTS_USE_REFINT)
AC_SUBST(TESTS_USE_MEMBEROF)
+AC_SUBST(TESTS_USE_MANAGED_ENTRIES)
AC_CONFIG_HEADER(src/config.h)
AC_OUTPUT(Makefile yp/Makefile src/Makefile
doc/examples/nis-plugin-example.ldif doc/examples/sch-plugin-example.ldif
tests/Makefile tests/clients/Makefile
tests/slapd.sh tests/config/dse.ldif.initial
- tests/config/dse.ldif.refint tests/config/dse.ldif.memberof
+ tests/config/dse.ldif.refint
+ tests/config/dse.ldif.memberof
+ tests/config/dse.ldif.mep
src/nisserver-plugin-defs.1)