summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorNalin Dahyabhai <nalin@dahyabhai.net>2013-08-06 13:55:17 -0400
committerNalin Dahyabhai <nalin@dahyabhai.net>2013-08-07 14:46:03 -0400
commit8b5fff4edc41f0e3d9bdeb8d39389754b4062dbe (patch)
treeff3b1cd941c20cfd36dbd323d8cf4abc7bd8119c /configure.ac
parent3e690a5fc81b1aefc17c1d92dfee5c06c035fe25 (diff)
downloadslapi-nis-8b5fff4edc41f0e3d9bdeb8d39389754b4062dbe.tar.gz
slapi-nis-8b5fff4edc41f0e3d9bdeb8d39389754b4062dbe.tar.xz
slapi-nis-8b5fff4edc41f0e3d9bdeb8d39389754b4062dbe.zip
Make --with-pam-service a build-time option
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 3a3789d..7cf576e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -323,6 +323,13 @@ AC_ARG_WITH(pam,
AS_HELP_STRING([--with-pam],
[use PAM API to authenticate users not found in the LDAP. Requires --with-nsswitch as well]),
use_pam=$withval,use_pam=AUTO)
+AC_ARG_WITH(pam-service,
+ AS_HELP_STRING([--with-pam-service=[[system-auth]]],
+ [select a PAM service name]),
+ pamservice=$withval,
+ pamservice=system-auth)
+AC_DEFINE_UNQUOTED(DEFAULT_PAM_SERVICE,"$pamservice",
+ [Define to name of the PAM service used when authenticating server-side users (system-auth).])
if test "x$use_nsswitch" = xno ; then
if test "x$use_pam" = xyes ; then