summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorNalin Dahyabhai <nalin@dahyabhai.net>2012-06-13 15:06:14 -0400
committerNalin Dahyabhai <nalin@dahyabhai.net>2012-06-13 15:06:14 -0400
commit78220857bd3c420fd2b09b1a83eaae23ec2e0c33 (patch)
tree89374acc9a2fda18f86e977721bdf7594d6336ad /configure.ac
parentc18ffce4be91de84a3c5e56895336829bdc16846 (diff)
downloadslapi-nis-78220857bd3c420fd2b09b1a83eaae23ec2e0c33.tar.gz
slapi-nis-78220857bd3c420fd2b09b1a83eaae23ec2e0c33.tar.xz
slapi-nis-78220857bd3c420fd2b09b1a83eaae23ec2e0c33.zip
drop support for directory server transactions
Transaction support the way we added it is an all-or-nothing proposition for a server installation, which turned out to be problematic, so 389 is going to pursue another strategy for that. The new way requires that we not register as a betxn plugin, ever.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac22
1 files changed, 0 insertions, 22 deletions
diff --git a/configure.ac b/configure.ac
index 0bcb8cd..66c978e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -105,10 +105,6 @@ dirsrv)
SLAPI_PLUGIN_INTERNAL_POST_MODIFY_FN,
SLAPI_PLUGIN_INTERNAL_POST_MODRDN_FN,
SLAPI_PLUGIN_INTERNAL_POST_DELETE_FN,
- SLAPI_PLUGIN_BE_TXN_POST_ADD_FN,
- SLAPI_PLUGIN_BE_TXN_POST_MODIFY_FN,
- SLAPI_PLUGIN_BE_TXN_POST_MODRDN_FN,
- SLAPI_PLUGIN_BE_TXN_POST_DELETE_FN,
NULL]
,,,
[AC_INCLUDES_DEFAULT
@@ -121,24 +117,6 @@ dirsrv)
else
thread_lock_api=POSIX
fi
- AC_MSG_CHECKING([whether to build with backend transaction support])
- USE_SLAPI_BE_TXNS=false
- if test x$ac_cv_have_decl_SLAPI_PLUGIN_BE_TXN_POST_ADD_FN = xyes ; then
- if test x$ac_cv_have_decl_SLAPI_PLUGIN_BE_TXN_POST_DELETE_FN = xyes ; then
- if test x$ac_cv_have_decl_SLAPI_PLUGIN_BE_TXN_POST_MODIFY_FN = xyes ; then
- if test x$ac_cv_have_decl_SLAPI_PLUGIN_BE_TXN_POST_MODRDN_FN = xyes ; then
- USE_SLAPI_BE_TXNS=true
- fi
- fi
- fi
- fi
- if $USE_SLAPI_BE_TXNS ; then
- AC_MSG_RESULT([yes])
- AC_DEFINE(USE_SLAPI_BE_TXNS,1,
- [Define to control whether or not the plugin attempts to process backend transactions.])
- else
- AC_MSG_RESULT([no])
- fi
;;
*)
RUNTIME_CFLAGS=