summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorNalin Dahyabhai <nalin@redhat.com>2012-03-15 19:50:45 -0400
committerNalin Dahyabhai <nalin@redhat.com>2012-03-15 19:50:45 -0400
commit6d78b63916f725300472b28c3c7b283afc72ac2e (patch)
tree3a6b31ef245d77d9549b698e012cd5866b8d894a /configure.ac
parent533ee3d75dd65eb6b4a6df0c718ddd16fadac33a (diff)
downloadslapi-nis-6d78b63916f725300472b28c3c7b283afc72ac2e.tar.gz
slapi-nis-6d78b63916f725300472b28c3c7b283afc72ac2e.tar.xz
slapi-nis-6d78b63916f725300472b28c3c7b283afc72ac2e.zip
- add setting of a synthetic entry's entryUSN based on the source entry's entryUSN or the root DSE's lastUSN (if we have no source entry)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac35
1 files changed, 24 insertions, 11 deletions
diff --git a/configure.ac b/configure.ac
index 9dc2bd3..0b2e6d8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -12,7 +12,7 @@ fi
AC_ARG_WITH(tcp-wrappers,
AS_HELP_STRING([--with-tcp-wrappers=AUTO],
- [use tcp-wrappers]),
+ [use tcp-wrappers]),
tcp_wrappers=$withval,tcp_wrappers=AUTO)
if test x$tcp_wrappers != xno ; then
AC_CHECK_HEADERS(tcpd.h)
@@ -34,7 +34,7 @@ AC_SUBST(LIBWRAP)
AC_ARG_WITH(tcp-wrappers-name,
AS_HELP_STRING([--with-tcp-wrappers-name=service],
- [tcp-wrappers and network service name (nis-plugin)]),
+ [tcp-wrappers and network service name (nis-plugin)]),
tcpwrapname=$withval,tcpwrapname=nis-plugin)
AC_DEFINE_UNQUOTED(DEFAULT_TCPWRAP_NAME,"$tcpwrapname",
[Define to the default application name to use when evaluating hosts.allow and hosts.deny.])
@@ -42,20 +42,20 @@ AC_SUBST(tcpwrapname)
AC_ARG_WITH(domain,
AS_HELP_STRING([--with-domain=[[example.com]]],
- [select a default domain name]),
+ [select a default domain name]),
mydomain=$withval,
mydomain=example.com)
mysuffix=`echo "$mydomain" | sed -e 's:^:dc=:g' -e 's:\.:, dc=:g'`
AC_ARG_WITH(server,
AS_HELP_STRING([--with-server=[[dirsrv]]],
- [select a specific server implementation (dirsrv)]),
+ [select a specific server implementation (dirsrv)]),
server=$withval,
server=dirsrv)
AC_ARG_WITH(ldap,
AS_HELP_STRING([--with-ldap=IMPL],
- [which LDAP library to use (none|mozldap|openldap)]),
+ [which LDAP library to use (none|mozldap|openldap)]),
ldapimpl=$withval,
ldapimpl=none)
@@ -255,13 +255,13 @@ myincludedir=`eval echo "$myincludedir" | sed "s,NONE,${ac_prefix},g"`
AC_ARG_WITH(users,
AS_HELP_STRING([--with-users=cn=Users],
- [select a specific user entry container (cn=Users)]),
+ [select a specific user entry container (cn=Users)]),
people=$withval,
people=[cn=Users])
AC_SUBST(people)
AC_ARG_WITH(groups,
AS_HELP_STRING([--with-groups=cn=Groups],
- [select a specific group entry container (cn=Groups)]),
+ [select a specific group entry container (cn=Groups)]),
groups=$withval,
groups=[cn=Groups])
AC_SUBST(groups)
@@ -403,7 +403,7 @@ AC_SUBST(TRACE_CMD)
CONFIGURED_LINK_FLAGS=
AC_ARG_ENABLE(unloading,
AS_HELP_STRING([--disable-unloading],
- [attempt to mark the plugins as not-to-be-unloaded]),
+ [attempt to mark the plugins as not-to-be-unloaded]),
if test x$enableval = xno ; then
AC_MSG_RESULT([marking plugins as not-to-be-unloaded])
[CONFIGURED_LINK_FLAGS='-Wl,-z,nodelete']
@@ -416,9 +416,10 @@ AC_SUBST(CONFIGURED_LINK_FLAGS)
TESTS_USE_REFINT=true
TESTS_USE_MEMBEROF=true
TESTS_USE_MANAGED_ENTRIES=true
+TESTS_USE_USN=true
AC_ARG_ENABLE(tests-with-refint,
AS_HELP_STRING([--disable-tests-with-refint],
- [skip tests which use the the refint plugin]),
+ [skip tests which use the the refint plugin]),
if test x$enableval = xyes ; then
AC_MSG_RESULT([running tests with referential integrity enabled])
else
@@ -428,7 +429,7 @@ AC_ARG_ENABLE(tests-with-refint,
AC_MSG_RESULT([running tests with referential integrity enabled]))
AC_ARG_ENABLE(tests-with-memberof,
AS_HELP_STRING([--disable-tests-with-memberof],
- [skip tests which are impacted by the memberof plugin]),
+ [skip tests which are impacted by the memberof plugin]),
if test x$enableval = xyes ; then
AC_MSG_RESULT([running tests with memberof enabled])
else
@@ -438,7 +439,7 @@ AC_ARG_ENABLE(tests-with-memberof,
AC_MSG_RESULT([running tests with memberof enabled]))
AC_ARG_ENABLE(tests-with-managed-entries,
AS_HELP_STRING([--disable-tests-with-managed-entries],
- [skip tests which are impacted by the managed entries plugin]),
+ [skip tests which are impacted by the managed entries plugin]),
if test x$enableval = xyes ; then
AC_MSG_RESULT([running tests with managed entries enabled])
else
@@ -446,9 +447,20 @@ AC_ARG_ENABLE(tests-with-managed-entries,
TESTS_USE_MANAGED_ENTRIES=false
fi,
AC_MSG_RESULT([running tests with managed entries enabled]))
+AC_ARG_ENABLE(tests-with-usn,
+ AS_HELP_STRING([--disable-tests-with-usn],
+ [skip tests which are impacted by the usn plugin]),
+ if test x$enableval = xyes ; then
+ AC_MSG_RESULT([running tests with usn enabled])
+ else
+ AC_MSG_RESULT([running tests with usn disabled])
+ TESTS_USE_USN=false
+ fi,
+ AC_MSG_RESULT([running tests with usn enabled]))
AC_SUBST(TESTS_USE_REFINT)
AC_SUBST(TESTS_USE_MEMBEROF)
AC_SUBST(TESTS_USE_MANAGED_ENTRIES)
+AC_SUBST(TESTS_USE_USN)
AC_CONFIG_HEADER(src/config.h)
AC_OUTPUT(Makefile yp/Makefile src/Makefile
@@ -458,4 +470,5 @@ AC_OUTPUT(Makefile yp/Makefile src/Makefile
tests/config/dse.ldif.refint
tests/config/dse.ldif.memberof
tests/config/dse.ldif.mep
+ tests/config/dse.ldif.usn
src/nisserver-plugin-defs.1)