summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorNalin Dahyabhai <nalin@dahyabhai.net>2011-08-12 15:31:53 -0400
committerNalin Dahyabhai <nalin@dahyabhai.net>2011-08-12 15:31:53 -0400
commit578a55b7374ad7e68da527f4035aeac967cc8906 (patch)
treef9f90a55f2b45fa85207b691840587771aab8c94 /configure.ac
parente1319619681dbef893866393c010261ea0256f9e (diff)
downloadslapi-nis-578a55b7374ad7e68da527f4035aeac967cc8906.tar.gz
slapi-nis-578a55b7374ad7e68da527f4035aeac967cc8906.tar.xz
slapi-nis-578a55b7374ad7e68da527f4035aeac967cc8906.zip
- separate which thread creation/manipulation/destruction API we use
from which rwlock creation/manipulation/destruction API we use
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 903aedc..5af37aa 100644
--- a/configure.ac
+++ b/configure.ac
@@ -95,6 +95,7 @@ dirsrv)
CFLAGS="$saved_CFLAGS"
LIBS="$saved_LIBS"
AC_DEFINE(USE_NSPR_THREADS,1,[Define to use NSPR threading functions.])
+ AC_DEFINE(USE_NSPR_LOCKS,1,[Define to use NSPR read/write locks.])
;;
*)
RUNTIME_CFLAGS=
@@ -106,6 +107,7 @@ dirsrv)
AC_ERROR([<slapi-plugin.h> not found])
fi
AC_DEFINE(USE_PTHREADS,1,[Define to use POSIX threading functions.])
+ AC_DEFINE(USE_PTHREAD_LOCKS,1,[Define to use POSIX read/write locks.])
saved_LIBS="$LIBS"
LIBS=
AC_CHECK_FUNC(pthread_create,,AC_CHECK_LIB(pthread,pthread_create))