summaryrefslogtreecommitdiffstats
path: root/install/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'install/Makefile.am')
-rw-r--r--install/Makefile.am50
1 files changed, 50 insertions, 0 deletions
diff --git a/install/Makefile.am b/install/Makefile.am
new file mode 100644
index 000000000..e57818cdc
--- /dev/null
+++ b/install/Makefile.am
@@ -0,0 +1,50 @@
+# This file will be processed with automake-1.7 to create Makefile.in
+#
+AUTOMAKE_OPTIONS = 1.7
+
+NULL =
+
+SUBDIRS = \
+ conf \
+ html \
+ share \
+ tools \
+ updates \
+ $(NULL)
+
+install-exec-local:
+ mkdir -p $(DESTDIR)$(localstatedir)/lib/ipa/sysrestore
+ chmod 700 $(DESTDIR)$(localstatedir)/lib/ipa/sysrestore
+ mkdir -p $(DESTDIR)$(localstatedir)/cache/ipa/sessions
+ chmod 700 $(DESTDIR)$(localstatedir)/cache/ipa/sessions
+
+uninstall-local:
+ -rmdir $(DESTDIR)$(localstatedir)/lib/ipa/sysrestore
+ -rmdir $(DESTDIR)$(localstatedir)/lib/ipa
+ -rmdir $(DESTDIR)$(localstatedir)/cache/ipa/sessions
+ -rmdir $(DESTDIR)$(localstatedir)/cache/ipa
+
+DISTCLEANFILES = \
+ $(NULL)
+
+MAINTAINERCLEANFILES = \
+ *~ \
+ intltool-*.in \
+ compile \
+ configure \
+ COPYING \
+ INSTALL \
+ install-sh \
+ missing \
+ mkinstalldirs \
+ config.guess \
+ ltmain.sh \
+ config.sub \
+ depcomp \
+ Makefile.in \
+ config.h.* \
+ aclocal.m4 \
+ version.m4 \
+ ipa-client.spec \
+ py-compile \
+ $(NULL)