summaryrefslogtreecommitdiffstats
path: root/ipa-server/xmlrpc-server/Makefile.am
diff options
context:
space:
mode:
authorRob Crittenden <rcritten@redhat.com>2008-01-18 16:20:36 -0500
committerRob Crittenden <rcritten@redhat.com>2008-01-18 16:20:36 -0500
commit042fb11fa107718a831d468d16188e02f6ae3712 (patch)
treee0e8ee6701800b8f03702cb338f8efa211b18046 /ipa-server/xmlrpc-server/Makefile.am
parentaaa3cfd58ca0c62325d7637b67c6711660624f5d (diff)
downloadfreeipa-042fb11fa107718a831d468d16188e02f6ae3712.tar.gz
freeipa-042fb11fa107718a831d468d16188e02f6ae3712.tar.xz
freeipa-042fb11fa107718a831d468d16188e02f6ae3712.zip
Fix issues reported by rpmlint.
- Removing shebangs (#!) from a bunch of python libraries - Don't use a variable name in init scripts for the lock file - Keep the init script name consistent with the binary name, so renamed ipa-kpasswd.init to ipa_kpasswd.init - Add status option to the init scripts - Move most python scripts out of /usr/share/ipa and into the python site-packages directories (ipaserver and ipaclient) - Remove unnecessary sys.path.append("/usr/share/ipa") - Fix the license string in the spec files - Rename ipa-webgui to ipa_webgui everywhere - Fix a couple of issues reported by pychecker in ipa-python
Diffstat (limited to 'ipa-server/xmlrpc-server/Makefile.am')
-rw-r--r--ipa-server/xmlrpc-server/Makefile.am8
1 files changed, 6 insertions, 2 deletions
diff --git a/ipa-server/xmlrpc-server/Makefile.am b/ipa-server/xmlrpc-server/Makefile.am
index 5e9da0651..cf1420197 100644
--- a/ipa-server/xmlrpc-server/Makefile.am
+++ b/ipa-server/xmlrpc-server/Makefile.am
@@ -10,10 +10,14 @@ html_DATA = \
unauthorized.html \
$(NULL)
-serverdir = $(IPA_DATA_DIR)/ipaserver
-server_PYTHON = \
+coredir = $(pythondir)/ipaserver
+core_PYTHON = \
attrs.py \
funcs.py \
+ $(NULL)
+
+serverdir = $(IPA_DATA_DIR)/ipaserver
+server_PYTHON = \
ipaxmlrpc.py \
$(NULL)