summaryrefslogtreecommitdiffstats
path: root/ipa-server/ipa-gui/setup.py
diff options
context:
space:
mode:
authorrcritten <devnull@localhost>2007-09-10 16:33:01 -0400
committerrcritten <devnull@localhost>2007-09-10 16:33:01 -0400
commit182fbe30945a8de005f00b460968dca7973342fb (patch)
tree644f8efd633cbb41a387fb33e3deab8de20718b5 /ipa-server/ipa-gui/setup.py
parent37d10e0c51dc289d815c05cd4d051e9d4120399e (diff)
downloadfreeipa-182fbe30945a8de005f00b460968dca7973342fb.tar.gz
freeipa-182fbe30945a8de005f00b460968dca7973342fb.tar.xz
freeipa-182fbe30945a8de005f00b460968dca7973342fb.zip
Enable mod_proxy to sit in front of TurboGears and pass along the
kerberos principal name Add an identity an visit class to TurboGears that can handle the user without requiring a database Update the UI to show the user correctly. Note that this is currently disabled. It is hardcoded to always return the principal test@FREEIPA.ORG in proxyprovider.py It doesn't handle an unauthorized request because that can never happen.
Diffstat (limited to 'ipa-server/ipa-gui/setup.py')
-rw-r--r--ipa-server/ipa-gui/setup.py6
1 files changed, 6 insertions, 0 deletions
diff --git a/ipa-server/ipa-gui/setup.py b/ipa-server/ipa-gui/setup.py
index 371325f6a..123817999 100644
--- a/ipa-server/ipa-gui/setup.py
+++ b/ipa-server/ipa-gui/setup.py
@@ -58,5 +58,11 @@ setup(
# 'Framework :: TurboGears :: Widgets',
],
test_suite = 'nose.collector',
+ entry_points = """
+ [turbogears.identity.provider]
+ proxyprovider = ipagui.proxyprovider:ProxyIdentityProvider
+ [turbogears.visit.manager]
+ proxyvisit = ipagui.proxyvisit:ProxyVisitManager
+ """,
)